Support » Plugin: Google Analyticator » [Plugin: Google Analyticator] Google_AuthException – why just on this domain?

  • Resolved Peter Le C

    (@peter-le-c)


    Hi Ben,

    6.3.2 now running on all of my blogs bar one.

    All sites on same server, all running same version of WP and up to date themes, no issues with the theme on other domains. (WeaverII)

    I deactivated and deleted and reinstalled GA twice to no avail so a bit of a head scratch…. can you assist?

    The domain isn’t new BTW.

    Thanks

    Fatal error: Uncaught exception ‘Google_AuthException’ with message ‘Error refreshing the OAuth2 token, message: ‘{ “error” : “invalid_grant” }” in /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php:279 Stack trace: #0 /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(239): Google_OAuth2->refreshTokenRequest(Array) #1 /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(216): Google_OAuth2->refreshToken(‘1/GANsPbyDZFm_5…’) #2 /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/service/Google_ServiceResource.php(166): Google_OAuth2->sign(Object(Google_HttpRequest)) #3 /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/contrib/Google_AnalyticsService.php(54): Google_ServiceResource->__call(‘list’, Array) #4 /home/dirtytal/publi in /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 279

    http://wordpress.org/extend/plugins/google-analyticator/

Viewing 15 replies - 16 through 30 (of 35 total)
  • This is indeed a weird one!

    So, the site that doesn’t work – site x – what is different about it?

    To manually remove all the settings from the DB – go to phpMyAdmin for site x’s database and open wp_options

    View post on imgur.com

    Click Search and enter ga_% for the option name

    View post on imgur.com

    That will show you all the values we are about to delete.

    Now, click on SQL tab

    paste in

    delete from wp_options where option_name like 'ga_%'

    And run that. It will delete all options prefixed with ga_ from the wp_options table.

    That will totally delete all Google Analyticator preferences from the DB.

    Ben

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Wrangler

    Peter beat me to the reply! I have multiple sites in this hosting account, but this is the only one with a GA issue. Seems like it HAS to be something else…

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Wrangler

    I don’t think I should start mucking about in the database because my affected site is one of 40+ in a multisite install. I’m afraid I’d create more issues than I’d solve! But I am interested in resolving this, so let me know if there’s anythng else I can do that would be helpful.

    Hi Ben 😉

    <So, the site that doesn’t work – site x – what is different about it?>

    Content is the only variable.

    I vary the header widths of my blogs and sundry decorative items to try and reduce sameness with the Great Google, but the blogs run with exactly the same plugins, exactly the same WP and i just use FireFox as my browser when doing any WP work.

    I thank you for the mySql screenshot, here in Moldova ( Eastern Europe) it’s getting late, I’ve had a drink and that combination is a no no for the obvious reasons! I’ll check tomorrow! Thanks for your help!

    😉

    Peter

    I don’t think I should start mucking about in the database because my affected site is one of 40+ in a multisite install. I’m afraid I’d create more issues than I’d solve! But I am interested in resolving this, so let me know if there’s anythng else I can do that would be helpful.

    Oh- hang on – Peter is yours also a Multisite install? Or individual installs?

    @bethannon1 – Yes If you are running multisite, dont do what I mentioned above, or it will wipe for all the sites the GA settings!

    So GA is working for most of your sites on the same MU site, yea? apart from just one

    Ben all my installs are individual.

    All working apart from the one. I am serious when i say my sites are simple replicated ones that earn be $30-50 a day every day so I keep it simple. Same boring settings… don’t mend what isn’t broken premise!

    Best Regards

    Peter

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Wrangler

    Just the one site in this multisite install is having GA issue.

    I changed line 224 in /plugins/google-analyticator/class.analytics.stats.php from

    ‘ga:’ . $this->accountId,

    to this:

    $this->accountId,

    And the error messages have gone away. The analytics code still appears on the pages; we’ll see tomorrow whether the reports are still working the way they should.

    @tommcgee I just tried that fix and I’m still getting this error:

    GA is working fine in all of my other blogs. They’re all hosted on the same server (though they’re individual installs. The only real difference with this one is that it’s a subdomain and the others aren’t. Could that be messing things up somehow?

    Fatal error: Uncaught exception ‘Google_ServiceException’ with message ‘Error calling GET https://www.googleapis.com/analytics/v3/data/ga?ids=ga%3Ablog.peculiarplace.com&start-date=2012-08-18&end-date=2012-09-17&metrics=ga%3Avisits&dimensions=ga%3Adate&sort=ga%3Adate: (400) Invalid value ‘ga:blog.peculiarplace.com’. Values must match the following regular expression: ‘ga:[0-9]+” in /home/peculiarblog/blog.peculiarplace.com/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_REST.php:66 Stack trace: #0 /home/peculiarblog/blog.peculiarplace.com/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_REST.php(36): Google_REST::decodeHttpResponse(Object(Google_HttpRequest)) #1 /home/peculiarblog/blog.peculiarplace.com/wp-content/plugins/google-analyticator/google-api-php-client/src/service/Google_ServiceResource.php(177): Google_REST::execute(Object(Google_HttpRequest)) #2 /home/peculiarblog/blog.peculiarplace.com/wp-content/plugins/google-analyticator/google-api-php-client/src/contr in /home/peculiarblog/blog.peculiarplace.com/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_REST.php on line 66

    Hi All,

    I believe I’ve been able to figure out the problem here, and it being an old variable used in 6.2 and the old system.

    Working on a fix now. Should be up in a couple hours!

    Ben

    Please update to latest version and let us know if it’s fixed the problem!

    Ben

    Updated and sorry to say, no cigar:>

    Fatal error: Uncaught exception ‘Google_AuthException’ with message ‘Error refreshing the OAuth2 token, message: ‘{ “error” : “invalid_grant” }” in /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php:279 Stack trace: #0 /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(239): Google_OAuth2->refreshTokenRequest(Array) #1 /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(216): Google_OAuth2->refreshToken(‘1/GANsPbyDZFm_5…’) #2 /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/service/Google_ServiceResource.php(166): Google_OAuth2->sign(Object(Google_HttpRequest)) #3 /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/contrib/Google_AnalyticsService.php(54): Google_ServiceResource->__call(‘list’, Array) #4 /home/dirtytal/publi in /home/dirtytal/public_html/very/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 279

    Cancel that.
    I hit reset after doing the update that sorted it.
    Now working on all my blogs 😉
    Thanks for your perseverance! Hopefully all input helps.

    Best regards

    Peter

    Good to hear Peter!

    If you wouldn’t mind, would you go to the plugin page and under compatibility, select “Works”

    Will mark this as resolved, as it was originally your post!

    cheers,
    Ben

    Hi.

    I had the same problem. I’ve just updated the plugin, i took another Google Authentication Code, i inserted it. Now, i have a bigger error 🙂

    Uncaught exception ‘Google_ServiceException’ with message ‘Error calling GET https://www.googleapis.com/analytics/v3/data/ga?ids=ga%3Aga%3A58403231&start-date=2012-08-20&end-date=2012-09-18&metrics=ga%3Avisitors: (400) Invalid value ‘ga:ga:58403231’. Values must match the following regular expression: ‘ga:[0-9]+” in /home/licart/public_html/raduherjeu.ro/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_REST.php:66 Stack trace: #0 /home/licart/public_html/raduherjeu.ro/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_REST.php(36): Google_REST::decodeHttpResponse(Object(Google_HttpRequest)) #1 /home/licart/public_html/raduherjeu.ro/wp-content/plugins/google-analyticator/google-api-php-client/src/service/Google_ServiceResource.php(177): Google_REST::execute(Object(Google_HttpRequest)) #2 /home/licart/public_html/raduherjeu.ro/wp-content/plugins/google-analyticator/google-api-php-client/src/contrib/Google_AnalyticsService.php(274): Google_ServiceResource->__cal in /home/licart/public_html/raduherjeu.ro/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_REST.php on line 66

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘[Plugin: Google Analyticator] Google_AuthException – why just on this domain?’ is closed to new replies.