Support » Plugin: Google Analyticator » [Plugin: Google Analyticator] error msg: Uncaught exception 'Google_IOException'

  • ResolvedModerator Bet Hannon

    (@bethannon1)


    Support Team Volunteer Coordinator

    Ok. Most of my sites are now updated & authenticated just fine. But one of them I can’t get to authenticate. I put in the GA auth code, and this error pops up:

    Fatal error: Uncaught exception ‘Google_IOException’ with message ‘HTTP Error: (0) error setting certificate verify locations: CAfile: /etc/ssl/certs/ca-certificates.crt CApath: none ‘ in /users/cctnet.com/htdocs/illuminarias-blog/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_CurlIO.php:128 Stack trace: #0 /users/cctnet.com/htdocs/illuminarias-blog/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(101): Google_CurlIO->makeRequest(Object(Google_HttpRequest)) #1 /users/cctnet.com/htdocs/illuminarias-blog/wp-content/plugins/google-analyticator/google-api-php-client/src/Google_Client.php(133): Google_OAuth2->authenticate(Array, ‘4/-QsFY0ccQQMlQ…’) #2 /users/cctnet.com/htdocs/illuminarias-blog/wp-content/plugins/google-analyticator/class.analytics.stats.php(69): Google_Client->authenticate(‘4/-QsFY0ccQQMlQ…’) #3 /users/cctnet.com/htdocs/illuminarias-blog/wp-content/plugins/google-analyticator/google-analyticator.php(856): GoogleAnalyticsStats->checkLogi in /users/cctnet.com/htdocs/illuminarias-blog/wp-content/plugins/google-analyticator/google-api-php-client/src/io/Google_CurlIO.php on line 128

    http://wordpress.org/extend/plugins/google-analyticator/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Coordinator

    I authenticated and got the dashboard widget to display in more than 40 sites yesterday. But today, almost all of them are displying this error — Another authorization issue…

    Suggestions?

    Fatal error: Uncaught exception ‘Google_AuthException’ with message ‘Error refreshing the OAuth2 token, message: ‘{ “error” : “invalid_grant” }” in /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php:279 Stack trace: #0 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(239): Google_OAuth2->refreshTokenRequest(Array) #1 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(216): Google_OAuth2->refreshToken(‘1/IM9jPtELSMB1g…’) #2 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/service/Google_ServiceResource.php(166): Google_OAuth2->sign(Object(Google_HttpRequest)) #3 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google in /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 279

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Coordinator

    Hello? I hope support requests are still being answered….

    I have tried several times authenticating sites, which works fine, and the widget displays in the dashboard, and THEN, the next day, I have this error message in the widget:

    Fatal error: Uncaught exception ‘Google_AuthException’ with message ‘Error refreshing the OAuth2 token, message: ‘{ “error” : “invalid_grant” }” in /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php:279 Stack trace: #0 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(239): Google_OAuth2->refreshTokenRequest(Array) #1 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(216): Google_OAuth2->refreshToken(‘1/jveIWbi6iAZlG…’) #2 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/service/Google_ServiceResource.php(166): Google_OAuth2->sign(Object(Google_HttpRequest)) #3 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google in /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 279

    I’m getting this same error on both my multisite install sites and single instal sites.

    Is there some reason that the authentication from Google goes through initially, but somehow “expires” or times out?

    I’ve re-authenticated a couple of sites. I’ll try to watch them through the day and let you know how long it takes for them to start throwing errors.

    Bet

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Coordinator

    I’m still getting the same error:

    Uncaught exception ‘Google_AuthException’ with message ‘Error refreshing the OAuth2 token, message: ‘{ “error” : “invalid_grant” }” … auth/Google_OAuth2.php on line 279

    A few of my sites (both single install & multisite) seem to “hold” the authorization & show the dashboard widget just fine. Most of them (again both singles & multisite sub-sites with their own domain names) are throwing this error within a day or two of having been re-authorized.

    Suggestions?

    Ops, posting error.

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Coordinator

    I am still having fatal error messages! I authorize through Google just fine, and get the dashboard widget to display, but on a number of sites, within 2-3 days, I’m getting this fatal error again.

    I re-authorize, get the dashboard widget to display, and then in another 2-3 days, I’m getting fatal errors again.

    What’s going on? Help!

    Hi Beth

    There are a couple of people with this error. It appears to be the Google system refreshing the auth token, and causing this error.

    We are looking at this currently, and hope to release a new update (6.3) Within the next week.

    Thanks, Ben

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Coordinator

    That update can’t come fast enough for me! 🙂

    Hey Beth would you be willing to try a beta of the plugin to see if it fixes your problem?
    Ben

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Coordinator

    Yes. Where can I email you info?

    Say hi to info @ videousermanuals.com attn Ben and I’ll flick you a beta to try out, thanks!

    I am having a similar problem – was there ever an ultimate fix to the issue?

    having the same problem!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Google Analyticator] error msg: Uncaught exception 'Google_IOException'’ is closed to new replies.