Support » Plugin: Google Analyticator » [Plugin: Google Analyticator] Dashboard widget stopped working

  • Resolved dancriel

    (@dancriel)


    I see the following in my error log:

    PHP Fatal error: GoogleAnalyticsSummary::getVisitsGraph() [<a href='googleanalyticssummary.getvisitsgraph'>googleanalyticssummary.getvisitsgraph</a>]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition &quot;Google_GaData&quot; of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /wp-content/plugins/google-analyticator/google-analytics-summary-widget.php on line 242

    Did Google’s API change again? This happening for anyone else?

    http://wordpress.org/extend/plugins/google-analyticator/

Viewing 15 replies - 1 through 15 (of 18 total)
  • I don’t see that on any of our installations.

    Did you try to deauthorize and reauthorize again?

    Brian

    Yes I tried that and I get the same error…is there any additional debug info I can provide to help troubleshoot?

    I tried deauth / reauth a few more times and it eventually started working.

    And 15 minutes later it is failing again with the same error as before. Help?

    I have 2 sites in GA with the same name, though the UIDs are unique the “name” of the 2 sites are the same… could this be related? The GA tracking code is working properly, only the dashboard widget is broken.

    Same here. If I have the widget installed then the site has no content from my pages. If I remove it then the site is normal.

    Edit:

    oops, strike that. I saw widget and was thinking sidebar widgets. For me the sidebar widget breaks the site.

    (I don’t see a way to delete a post, so I edited my comment)

    Update: I determined that the failure was occurring while trying to retrieve cached GA data from the DB. As a workaround, I stopped the dashboard widget from attempting to use cached data so it makes a fresh call each time. In google-analytics-summary-widget.php I commented out lines 210, 282, 358, 453, and 505. Now my dashboard summary widget works again.

    In case Brian is still monitoring this thread, I had to make another small change to this plugin to get it working properly with my site.

    In google-analyticator.php on line 456 the plugin attempts to auto-select a GA account whose ‘name’ matches that of your site. As I mentioned earlier in this thread somehow I have 2 GA accounts with the same name, and that line of code was causing the HTML <select> element at the top of the plugin settings page to render with two options selected at the same time. Like this:

    <option value="UA-[...]-1" selected="selected">www.mysite.com</option>
    <option value="UA-[...]-2" selected="selected">www.mysite.com</option>

    Brian, thanks for the great plugin, greatly appreciate you keeping it up to date with Google’s fluctuating API.

    Thanks so much for letting us know.

    We will take a look at this.

    Great to have such detailed feedback.

    FYI – I have exactly the same error. This plug-in worked without error the last time I visited the dashboard (a few weeks ago).

    Just dropping by this thread again to say that all the problems I outlined in my posts above still exist with plugin version 6.4, and the same fixes (hacks) that I provided can be re-applied if your dashboard widget stops working after the update.

    The line numbers have changed, but you can open google-analytics-summary-widget.php, search for the word “unserialize”, and comment out each line that begins with $cached = maybe_unserialize(… there should be 4 instances.

    Hi dancriel –

    sorry I missed the 2nd part to your post. I thought we had the dropdown bug sorted (which we do).

    I’ll take a quick look at this now for you and release a patch.

    Ben

    My dashboard widget stopped working as well, though I’m not seeing an error displaying–the widget just hangs at “loading.” Anyone else getting this?

    A look at my log shows this, though I’m not certain it’s from this plugin:
    _transient_timeout_dash_de3249c4736ad3bd2cd29147c4a0d43e deleted.

    Not sure if this is the same error or fix that dancriel describes.

    Many thanks for any info.

    for me too, Google Analyticator make bug with widget…

    Hi @devrap

    Are you still having the problem? Yes we are using transients to store the data from google, for around 12hours I think.

    If you have WP_DEBUG enabled, we don’t use the transient. If you wanted to turn on WP_DEBUG that will show if the transient is causing the issues.

    Hi @moi-jeux

    Can I have some more information?

    Cheers

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Google Analyticator] Dashboard widget stopped working’ is closed to new replies.