Support » Plugin: Google Analyticator » [Plugin: Google Analyticator] analyticsFileTypes' is undefined

  • Hello guys,

    I have only a problem on my wp-admin page. So that’s very weird. On every other pages, the code is fine but here is what I get for the wp-admin one:

    Message : ‘analyticsFileTypes’ is undefined

    URI : ***/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.1.2

    Do you know how to fix that ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Aware of the issue and have a fix. Will be resolved in the next release, hopefully this weekend. If it’s a deal breaker, disabling Outbound Link Tracking will prevent the error for now.

    this issue still exists in 6.1.3.
    I got this issue in combination with fotoslide.

    The error popups when trying to select an image from the media library.

    Hi, still it exists… But I see it occurring only when user tracking is enabled and when previewing a post. It does not happen after publishing the post.

    So it’s not a real big deal but there is a nasty side-effect: the error breaks other jQuery script like FancyBox to fire up so when previewing posts or pages, it looks like the images do not open correctly while only after publishing, it does all work correctly.

    So I propose the following change to the function ga_external_tracking_js() in google-analyticator.php :

    /**
     * Adds the scripts required for outbound link tracking
     **/
    function ga_external_tracking_js()
    {
    	# Disable the tracking code on the post preview page
    	if ( !function_exists("is_preview") || ( function_exists("is_preview") && !is_preview() ) )
    	{
    
    		wp_enqueue_script('ga-external-tracking', plugins_url('/google-analyticator/external-tracking.min.js'), array('jquery'), GOOGLE_ANALYTICATOR_VERSION);
    	}
    }

    Tried and tested but any alternative with the same effect would be most welcome 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Google Analyticator] analyticsFileTypes' is undefined’ is closed to new replies.