Support » Plugins » [Plugin: Global Translator] Stopped working after months: php_network_getaddresses: getaddrinfo fail

  • Resolved Thomas L

    (@thomaz)


    Hi,
    I’ve been using Global Translator for months and it has been doing a great work.
    However it has stopped working and the debug file shows the following.
    Any idea?

    A friend of mine is getting exactly the same problem, we are running on fedora.

    2009-04-01 20:16:31 [from: 88.159.74.199|Mozilla/5.0] – gltr_patch_translation_url :: Google Patched:
    2009-04-01 20:16:31 [from: 88.159.74.199|Mozilla/5.0] – Bad translated content for url: http://www.liajnad.se/archives/1746/
    php_network_getaddresses: getaddrinfo failed: Name or service not known (0)

Viewing 15 replies - 1 through 15 (of 16 total)
  • All three of my blogs (hosted on separate servers) have stopped working with Global Translator. Bad translated content, Bad or unhandled response.

    Increasing the time to send requests does not help. The plugin appears to be dead.

    Same here.

    2009-04-02 02:53:25 [from: 66.249.71.197|Mediapartners-Google] – gltr_clean_url_to_translate :: [REWRITEON] self url:http://sharebrain.info/ru/ | url_to_translate:http://sharebrain.info
    2009-04-02 02:53:25 [from: 66.249.71.197|Mediapartners-Google] – gltr_get_page_content :: Connecting to engine for url:http://sharebrain.info
    2009-04-02 02:53:25 [from: 66.249.71.197|Mediapartners-Google] – gltr_clean_url_to_translate :: [REWRITEON] self url:http://sharebrain.info/ru/ | url_to_translate:http://sharebrain.info
    2009-04-02 02:53:25 [from: 66.249.71.197|Mediapartners-Google] – gltr_is_connection_allowed :: Allowing connection request: delta=673 secs
    2009-04-02 02:53:25 [from: 66.249.71.197|Mediapartners-Google] – gltr_patch_translation_url :: Google Patched:
    2009-04-02 02:53:25 [from: 66.249.71.197|Mediapartners-Google] – Bad translated content for url: http://sharebrain.info
    php_network_getaddresses: getaddrinfo failed: Name or service not known (0)

    2009-04-02 02:53:25 [from: 66.249.71.197|Mediapartners-Google] – gltr_get_page_content :: translation not available. Switching to stale for url: http://sharebrain.info
    2009-04-02 02:53:25 [from: 66.249.71.197|Mediapartners-Google] – gltr_get_page_content :: returning stale version (_ru) for url:http://sharebrain.info
    2009-04-02 02:53:26 [from: 222.124.207.5|Mozilla/5.0] – gltr_get_page_content :: returning cached version (_id_category_tutorials_graphic-design-tutorials) for url:http://sharebrain.info/id/category/tutorials/graphic-design-tutorials/
    2009-04-02 02:53:39 [from: 66.249.71.197|Mediapartners-Google] – gltr_clean_url_to_translate :: [REWRITEON] self url:http://sharebrain.info/pl/ | url_to_translate:http://sharebrain.info
    2009-04-02 02:53:39 [from: 66.249.71.197|Mediapartners-Google] – gltr_get_page_content :: Connecting to engine for url:http://sharebrain.info
    2009-04-02 02:53:39 [from: 66.249.71.197|Mediapartners-Google] – gltr_clean_url_to_translate :: [REWRITEON] self url:http://sharebrain.info/pl/ | url_to_translate:http://sharebrain.info
    2009-04-02 02:53:39 [from: 66.249.71.197|Mediapartners-Google] – gltr_is_connection_allowed :: Allowing connection request: delta=687 secs
    2009-04-02 02:53:39 [from: 66.249.71.197|Mediapartners-Google] – gltr_patch_translation_url :: Google Patched:
    2009-04-02 02:53:39 [from: 66.249.71.197|Mediapartners-Google] – Bad translated content for url: http://sharebrain.info
    php_network_getaddresses: getaddrinfo failed: Name or service not known (0)

    2009-04-02 02:53:39 [from: 66.249.71.197|Mediapartners-Google] – gltr_get_page_content :: translation not available. Switching to stale for url: http://sharebrain.info
    2009-04-02 02:53:39 [from: 66.249.71.197|Mediapartners-Google] – gltr_get_page_content :: returning stale version (_pl) for url:http://sharebrain.info

    Any idea???

    thx a lot !

    Same problem for me … sad… I hope the plugin is not dead though !

    Same problem here.

    The explanation COULD be the following one : Google has changed its URL for translation. I’ll make some tests and let you know if it works.

    *** making tests ***

    URL provided by the plugin is :

    http://translate.google.com/translate?hl=en&ie=UTF-8&oe=UTF-8&langpair=${SRCLANG}|${DESTLANG}&u=${URL}&prev=/language_tools

    URL provided by Google when I translate a page is :

    http://translate.google.com/translate?hl=en&ie=UTF-8&oe=UTF-8&langpair=fr|en&u=http://www.myurl.com&prev=/language_tools

    Well … !!! I see no difference …

    I have no idea what to do so far … 🙁

    I wonder if the PRO vesion of the plugin has the same problem ?

    If a browser visits a page that has not yet been translated, the client would get the translated page from Google and upload it to the server (I dunno how this is possible though)…

    Hi all!
    Google has just changed its translation URL, so all the old versions cannot work anymore!!
    I’ve just released a fix: please download the 1.2.2 version 🙂

    Davide Pozza

    Hi Davide!

    Can you post the link.
    Thanx.

    Thanx MatthewS!

    Thanks Davide!

    Now we are on the track again!

    Hello Davide,
    Or anyone who can help me..

    I am newbie in using wordpress
    i just download Global Translator and appear on my web successfully.
    But, when i try to click one of the flag, it shows up to “

    “HTTP 404 – File not found
    Oops! the link appears broken”

    What should i do to FIX it?

    Thanks

    The new plugin works and it rocks ! 🙂

    SR88, where is your web site ?
    Tell us the URL so that somebody here can try to help you…

    Hi Nairolf,

    visit my web at successrevolution.com

    Hope i can get a help.
    and absolutely it will be great if can work. a fantastic plug in

    Thanks anyway 🙂

    Hi Davide,

    Thanks for the fix. But how will my old pages get translated now? As with this fix it will work for newer pages. How to fix this?

    Thanks,
    wordpress_user1980

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Global Translator] Stopped working after months: php_network_getaddresses: getaddrinfo fail’ is closed to new replies.