Support » Fixing WordPress » [Plugin: Global Translator] receiving Google “403 Forbidden” error after one page translated

  • Hi Everyone,

    I love the wonderful concept of the Global Translator, and the great coding from the author that went into developing the plugin.

    However, I think that Google is catching on to the software, is recognizing it in its algorythms, and is sometimes or often blocking the plugin translation attempts.

    Again, I love to concept and hard work that went into the plugin, and I would love to see it work for my site (and other’s sites).

    I had installed and set the plugin to the recommended 300 seconds per translation attempt, and one page (in Italian was successfully translated).

    But then, the plugin was not successfully translating and caching any more pages through Google translation.

    When it was clear that Google was not translating any more pages and saving them to my site’s cache, I checked the error log, and found this error:

    “Bad translated content for url:”

    “403 Forbidden”

    “We’re sorry…but your query looks similar
    to automated requests from a computer virus or spyware
    application. To protect our users, we can’t process your request
    right now…. We’ll restore your access as quickly as possible, so try again soon. In the meantime, if you suspect that your computer or network has been infected, you might want to run a virus checker or spyware remover to make sure that your systems are free of viruses and other spurious software.”

    I tried what someone else suggested in another WordPress forum thread: after it seemed that Google was not translating any other pages, I changed the setting to 600 seconds per translation attempt. But I was still receiving the Google errors.

    Another note:

    Later, Yahoo spider was on my site and began spidering the links, and then after spidering a few language links, my log reported this error: “Blocking connection request: last_connection_time=1231341221 now=1231341317 delta=96 “

    Does anyone know how to make the global translation plugin acceptable to Google and not treated like SPAM?

    I don’t want Google to think that I am violating their use policy, and penalize or ban my site from SE results.

    I wonder if customozing the software bar a bit would make the installation different enough that Google would not recognize that it is an authomatic software accessing its translation pages?

    Thanks for your thoughts about how to resolve this.

    Khashyar

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello Again,

    I still have not found an answer to this issue.

    Does anyone know if Google blocks IP addresses from certain servers?

    I’m on a shared ipower server (with probably 800 other websites that use the same IP address).

    I wonder if a few other websites on this server have WordPress installed, and thus Google is limiting our access to their language translation because it treats all the WordPress installations on this server the same?

    Thank you your thoughts and feedback.

    Yes I run doreenvaliente.com and I have now deactivated this plugin due to the problems as above – shame because it would be such a useful feature to have on our website.

    same here 🙁

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Global Translator] receiving Google “403 Forbidden” error after one page translated’ is closed to new replies.