WordPress.org

Forums

GEO my WordPress
[resolved] [Plugin: GEO my WP] Disabled Friends feature in Buddypress error (9 posts)

  1. hmpluv
    Member
    Posted 2 years ago #

    Friend Connections
    request Friend
    request a Date

    GeoLocation Sucks

    Hi Love your Plugin!
    i think i am the 7th person to download the plugin(luckynumber)

    But i am having two problems
    1) the auto Location doesn't seem to yeild any results
    the search result simply states "location information is unavailable"
    after a while, (PS. I am using internet Explorer)

    2) I do not use the "friends" feature in Buddypress
    hence, when i do a proximty search i get this error
    and the Map does not show, only the posts show
    Fatal error: Call to undefined function friends_check_friendship_status() in /free/home/luvhancom/html/wp-content/plugins/geo-my-wp/plugins/wppl-friends-locator/template-functions.php on line 26

    when i simply //comment out the two lines
    Sidebar my widget avatar images become huge!
    but the maps and posts come out normally

    $friend_status = friends_check_friendship_status( $bp->loggedin_user->userdata->ID,$single_user->member_id);

    echo bp_get_add_friend_button( $single_user->member_id, $friend_status );

    I guess a temporary fix would be to disable the sidebar widgets
    only on the search nearby page.

    http://wordpress.org/extend/plugins/geo-my-wp/

  2. Eyal Fitoussi
    Member
    Plugin Author

    Posted 2 years ago #

    Ouch!!! nooby me. i didn't take that friendship connection settings into account. i'll come back with a temporary fix soon.

    about the first issue i do not think it is an IE issue ( have you tried a different browser?) but more of a location. what is your location?

  3. Eyal Fitoussi
    Member
    Plugin Author

    Posted 2 years ago #

    Ok,
    about the images size in you widget.
    go to the same "template-functions.php" file and in line 16 where it says <style> .item-avatar.... change it to wppl-item-avatar.

    then go to :
    geo-my-wp/plugins/wppl-friends-locator/themes/default/css/style.css
    and in lines 172 and 173 remove the "! important" next to the 80px.

    that will fix the issue and let you control the avatar size from the shortcode.

  4. hmpluv
    Member
    Posted 2 years ago #

    Oops!
    sorry the first few lines weren't meant for you T_T
    those lines were copied from a previous note about
    While i was trying to configure another geolocation plugin~
    seems i missed the time period to edit that out
    Sorry

    Love your Plugin~
    Gave your Plugin a ★★★★★

  5. Eyal Fitoussi
    Member
    Plugin Author

    Posted 2 years ago #

    no problem :)
    did you get everything fixed?

    BTW , i uploaded new update with a fix for the "friends connection" component. should be fine now.
    thank you for reporting

  6. hmpluv
    Member
    Posted 2 years ago #

    the 1.5.1 updates seems to fix the friends error message
    Thanks :) sorry about the previous mishap

    Regarding AutoLocation
    Well my Location is South Korea,
    So i currently have my country code as: KR
    would that be a problem for auto finding my location?
    Although i am currently in Korea, i am planning to create a community based in London and Later the US

    the explorer and firefox autolocatar buttons simple show the script "Just one more moment please. Getting your current location..."
    is it a permissions issue?
    and doesnt do much after that, in firefox i enabled the location finding feature,(didnt test chrome)

    bytheway the countrycode link in the GeomyWP settings(?) is blank, currently it leads to http://geomywp.com/wp-content/country-code.php "Page not found"

    Currently, i manually input the location for two members
    if the location information is manually input into the profile fields the nearby search works just fine

    Regarding the Avatar Size
    the avatar sizes of the sidebar widgets returned to normal after the 1.5.1update, but the avatars of the result page member's avatars are now monstrous,
    the result page avatars seem to be hieght 50px width 50px

    the previous fixes that your presented for the remedying the avatar sizes, no longer seem applicable as the files have changed

    there is no <style>.item-avatar on line 16 template-functions.php
    "template-functions.php" file and in line 16 where it says <style> .item-avatar.... change it to wppl-item-avatar.

    the 1.5.1 update line 16 is now
    echo '<div class="wppl-thumb">';

    then go to :
    geo-my-wp/plugins/wppl-friends-locator/themes/default/css/style.css
    and in lines 172 and 173 remove the "! important" next to the 80px.

    1.5.1 is now
    width: 80px;
    height: 80px;

  7. Eyal Fitoussi
    Member
    Plugin Author

    Posted 2 years ago #

    Hmpluv,,
    I believe that the auto locator issue connected to your location. There is another user that report the exacts same problem and I think he lives in Korea as well. I have been looking and googling this issue but cannot find nothing about it. I will keep working on it. And I don't think the country code will have any affect on it but you can just try to leave that empty. And thank you for letting me know about the country code page. I forgot to link it from the old WordPress places locator site. BTW, you'll be fine having a website based in a different country actually even if I will go to your current site right now it will work fine for me since it will recognize my location. It doesn't matter where the site is but where the user located.

    And About the avatar size . When I fixed the friends connection issue I fixed the avatar issue as well. That is why the files changed , I wrote you the instructions above before I uploded the fix. Now you suppose to be able to control the avatar size from the settings of the shortcode.
    Try that and let me know it that works.

  8. hmpluv
    Member
    Posted 2 years ago #

    Ok Thanks!
    will just have to hope that the autolocaiton will work
    when in London
    cheers

  9. Eyal Fitoussi
    Member
    Plugin Author

    Posted 2 years ago #

    No worries. I know for sure that it works there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.