Support » Fixing WordPress » [Plugin: GD Star Rating] Star Rating stays with “please wait”

  • Hi!
    I’ve a problem with the GD Star Rating plugin that the stars appear on the post pages but when I click on them only “please wait” appears and nothing happens.

    The url is http://www.elenija.de/

    It’s WordPress 2.7.1 with PHP 4.4.9 and the default theme. The w3 validator has checked the page successfully.

    I’ve deactivated all other plugins but it’s still the same. Do you have any thoughts on what might be causing this?

    Thanks!

Viewing 15 replies - 1 through 15 (of 19 total)
  • There is something wrong, I can see the response received from server, says that there is a problem with missing main function wehn ajax file tries to load it.

    This hasn’t happend before, and my guess that some PHP setting is causing the problem. I have tested plugin with PHP 4.4.8 and there were no problems, but there are some php.ini settingst that could be the problem. I will look into this.

    Thank you for the investigation. Please let me know if you need any additional information.

    I will have some changes tomorrow, and if you are willing to test current development version, I can upload it for you to try it.

    Of course I will try it.

    I’ve got a new warning when I edit a page in WordPress. At the bottom in the “GD Star Rating: Multi Rating Review” widget/portlet there is:


    Warning: Invalid argument supplied for foreach() in .../plugins/gd-star-rating/gd-star-rating.php on line 511
    You first need to select which multi set you want to use for review rating.

    May be you can have a look at it when you do bugfixing. I’m looking forward to the new version of your plugin. Thank you very much for your work!

    This is fixed, will be included with next release, most likely in the middle of next week.

    Hi Milan,

    I’ve tried the new version 1.1.8 but unfortunately it’s still not possible to rate. First, I did a full uninstall of the previous version from the GD Star Rating Setup, then removed the old gd-star-rating directory from the plugins directory and after that I’ve uploaded the new version.

    The only modification of the settings I did was the number of stars for posts. When I want to rate the stars disappears and “please wait” stays forever.

    It’s very strange. I’ve checked the problems you mentioned in the user guide and there should be everything ok. I’ve already disabled the other plugins. Is there something else I should verify? Can I provide you with addistional debug information?

    The URL is http://www.elenija.de/

    Thanks.

    This is a unique problem. Ajax code can’t find the main class. Do you have some specific server settings? What PHP and WP you use? Did you moved wp-content out of it’s default location?

    It’s a default installation of WP 2.7.1 DE-Edition from the german http://wordpress-deutschland.org/ with the default theme. The server is Apache/1.3.37 on SunOS (the provider is Strato), the PHP version is 4.4.9. I didn’t move the wp-content directory, it is at /.

    It’s most likely some server settings at Strato, but all the other things work without any problem, so it’s very strange…

    Anyway, thank you very much for your help!

    Well, that’s the problem. I can test further with old PHP4, but I can’t test with such old Apache server. I will try to fix the problem if the problem is caused by PHP.

    mek32390

    (@mek32390)

    To al72 or GDragon,

    I just visited the link that al72 posted. The rating system seems to work just fine. I was wondering how you fixed the problem? I am in the same exact situation. The stars show up on the page, but when clicked, the “please wait” goes on forever. I have the newest version of wordpress and 1.1.8 GD Star Rating. I am very lost. Here is a link to my page http://www.remix-nation.com/.

    Any help at all would be greatly appreciated.

    This is already answered on my blog. Many people are running the website on one server and the domain name is not pointing to the same server. So, your website is serving from ‘http://mek32390.fatcow.com’, and that’s different from the actual domain name. And ajax is not going to work due to cross domain restrictions in ALL the browsers.

    mek32390

    (@mek32390)

    ok thank you GDragon. So there is no fix to this problem as of now?

    This has nothing to do with the plugin, this is the way the AJAX works and nothing to fix.

    mek32390

    (@mek32390)

    ok thanks. I have gone and done some research throughout your tutorials. I have firebug for mozilla installed. I have run it and found that the error resides with the cross-domain ajax settings. This is what you were trying to tell me. Anyway, I have tried to research how to do something about this, but I cannot find anything. Is there just nothing I can do?

    Thanks.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: GD Star Rating] Star Rating stays with “please wait”’ is closed to new replies.