WordPress.org

Support

Support » Plugins and Hacks » GD Star Rating » [Plugin: GD Star Rating] Rich Snippet not showing in Google

[Plugin: GD Star Rating] Rich Snippet not showing in Google

  • Thanks for this awesome plugin.

    I have a problem that is not directly caused by your plugin. When Google index my site with GD Star Rating, it seems like ratings are not loaded fast enough and I can see from google cache that from Googlebot point of view my sites only show “GD Star Rating – Loading…”.

    Any tips how to avoid this and get those nice looking stars under SERPs?

    http://wordpress.org/extend/plugins/gd-star-rating/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Having the same problem with Weaver II theme using The Cart Press plugin. It’s not just appearing on the product pages, but also on the blog pages.

    Seems it was working fine up until the recent update.

    Stars are showing on the pages but cached pages are only showing GD Star Rating, A WordPress rating system”, and then the rating based on the total number of votes.

    When I check a page in Webmaster tools it shows:

    hcard
    fn = Robert
    nickname = Robert
    photo = http://1.gravatar.com/avatar/d231bb13d019b3539fe67fcd0fc54c47?s=40&d=http%3A%2F%2F1.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D40
    hcard
    fn = joe
    nickname = joe
    photo = http://0.gravatar.com/avatar/2c1a96faa04b26eb4f58aedfbe338795?s=40&d=http%3A%2F%2F0.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D40
    hcard
    fn = HIV Home Kit rapid home HIV instant test kits
    url = http://hivhomekit.com/
    photo = http://1.gravatar.com/avatar/5775d72be671c2a0a627163d44e66c01?s=32&d=http%3A%2F%2F1.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D32
    hcard
    fn = Rakti
    nickname = Rakti
    photo = http://0.gravatar.com/avatar/855a1abbe8f9784caab055584f505229?s=40&d=http%3A%2F%2F0.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D40
    hfeed
    hentry
    entry-title = Rapid HIV instant test kits
    entry-content = Price Units $13.99 (USD) Buy 2 or more HIV Home Kit rapid HIV instant test kits & save! Buy 1 HIV Home Kit rapid HIV instant test kit $13.99 + postage SAVE 10% Buy 2 HIV Home Kit rapid HIV...
    Rel
    name = Permalink to Rapid HIV instant test kits
    rel = bookmark
    url = http://hivhomekit.com/product/hiv-instant-test-kits/
    Warning: Missing required field "updated".
    Warning: Missing required hCard "author".

    I have no user named Joe, Robert or Rakti on this account.

    I was able to resolve this issue by modifying GD Star Rating code.

    They have a major flaw in their design, in which they “hide” the snippet data with inline CSS. Google doesn’t like this and therefore doesn’t render the ratings.

    Here’s how you fix it:

    MAKE A COPY OF THIS FILE BEFORE YOU EDIT IT!

    Open: /plugins/gd-star-rating/gdragon/gd_google.php

    Edit the following line numbers 89 & 149 from:

    $hidden = $options["hidden"] ? ' style="display: none !important;"' : '';

    TO:

    $hidden = $options["hidden"] ? ' style="position:absolute;left:-9999999px;"' : '';

    Save, upload, sit tight for 24 hours and Google will start showing your rating inline with your results.

    Good luck!

    Will make changes asap and I’ll let you know if this works. Thanks a lot for the tip!

    Thanks pmagony. I just made the changes and also wait to see if this helps.

    Did it work?

    Unfortunately not for me. Not showing up in snippets or Webmaster tools.

    Thanks for the suggestion though.

    The really annoying thing is I’ve got it working fine on other sites with the exact same settings, including other sites based on Weaver and it was working fine up until one or two updates ago and then it just stopped.

    As the developer is taking no interest in this unless he’s paid for support here is a solution that worked for me.

    Log in to your CPanel and go to phpMyAdmin
    Locate the appropriate databse
    Export the tables that contain your ratings, such as:
    wp_gdsr_data_article
    wp_gdsr_data_category
    wp_gdsr_data_comment

    Go to the WordPress dashboard and then to GDSR / settings / database maintenance
    Delete all database tables

    Then to / Remove settings and remove all plugin settings and all the saved widgets.

    Then to / Full Uninstall and click Uninstall. Note that the plugin does NOT become inactive after this as stated so then go to

    Installed plugins and delete GDSR

    Perform a clean install and go back to phpMyAdmin and import the tables exported earlier.

    After all of this go to Webmaster Tools and you should immediately see your stars reappear in Rich Snippets Testing Tool along with all of the votes you previously had.

    As I posted here and on the GDSR website, this error popped up in some of the websites we run GDSR on after one of the maintenance updates recently.

    This is the second time we’ve had to do do a clean install like this after a maintenance update – the first time we lost hundreds of review ratings.

    Give it a day or two and then check your server error logs to see if the reinstall stops GDSR throwing errors.

    Hope this helps others.

    @pattaya_web

    It worked like a charm for me!

    @ brando71

    Glad it worked for you 🙂

    thanks pmagony, it works.

    Hi to all
    I have a question.
    Since 2 Month, the “GD Star Rating Plugin” is installed. Rich Snippet Tool recognize the [code] but stars aren’t show in Google Search Result.
    Do I need the fix from “Pattaya_Web”.
    THank you fro any respond.
    Lejla

    Another way is go to the GD star ratting settings, click on the Special Tab
    Then disable
    “Snippet will be renedered hidden on the page (style display set to none).”

    Google doesn’t display the ratings as a snippets when those ratting are hidden for the end user

    Hello,

    I disabled that option but my ratings still don’t show on the Rich Snippet Testing Tool.

    What can I do to fix this besides messing around with the mysql tables?

    Thanks!

    Tried the uninstall/reinstall solution posted by Pattaya_Web but it’s still not working :\

    Ok, the problem in my case was that I was outputting Star Ratings like this:

    <?php wp_gdsr_render_article(10, false, ‘crystal’, 30); ?>

    and you need to render it through automatic output through:

    <?php the_content(”); ?>

    Since I was using Magic Fields to output the content I didn’t have it at all. Hope this helps someone else!

    EDIT: I didn’t want the ratings to get automatically positioned on my content div so I ended up using:


    <?php wp_gdsr_render_article(10, false, ‘crystal’, 30); ?>
    <?php do_action( ‘gdsr_gsr_insert_snippet’); ?>

    To display the ratings and the necessary snippet for Google. Disabled auto insertion of rating on individual posts and then the content output stopped displaying the ratings. (You should replace the render_article definitions with your custom style.)

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: GD Star Rating] Rich Snippet not showing in Google’ is closed to new replies.
Skip to toolbar