Support » Plugin: GD Star Rating » [Plugin: GD Star Rating] question regarding the implementation of microformats

  • Resolved Ovidiu

    (@ovidiu)


    when I use the Google Rich Snippets tool to test one of my posts, click here for an example.

    I see the following comment on my microformat implementation:

    Extracted rich snippet data from the page
    hreview-aggregate
    item fn = Spooky Sibiu
    rating
    best = 10
    average (normalized to 5.0 scale) = 5.0
    average = 10.0
    count = 1
    Warning: This information will not appear as a rich snippet in search results, because it is contained in a hidden HTML element. Except in special circumstances, Google won’t display content that is not visible to the user. You should mark up the text that actually appears to your users when they visit your web pages.
    Warning: If count is specified in review aggregate, page should contain reviews. Otherwise you may want to use votes. More information about aggregate reviews.

    Issue #1
    If I visit the settings page and navigate to the special tab I see that in the Google Rich Snippets section the following is selected: Snippet will be rendered hidden on the page (style display set to none).

    If I uncheck that, Google will no longer complain but every visitor sees the Rich Snippet text.

    Any solution for this issue? How are other people dealing with this?

    Issue #2
    Warning: If count is specified in review aggregate, page should contain reviews. Otherwise you may want to use votes.

    My posts don’t contain reviews, I only use this plugin to let visitors vote on some of my images. So I would actually want to display VOTES not COUNT. Any hint as to where to change this? The plugin is quite complicated I simply can’t find the right place to change this.

    http://wordpress.org/extend/plugins/gd-star-rating/

Viewing 14 replies - 1 through 14 (of 14 total)
  • same error here, i hope the dev team will correct this problem…

    not sure he is monitoring the forums, maybe we’re lucky…

    google team told me this:

    Thank you for your interest in rich snippets for your site. Unfortunately, Google can’t display rich snippets for your site evemilano.com because of the following issue:

    Your marked-up review uses “count” instead of “votes”. “count” specifies the total number of reviews for an item. “votes” specifies the number of people who provided a rating, with or without an accompanying review. A site can specify count or votes, or both.

    but i don’t know how switch from damn count to damn vote…
    this plugin brings me more problem than benefit

    rich snippet testing tool result:

    Extracted rich snippet data from the page
    hreview-aggregate
    item fn = Adwords: aumentare il CTR
    rating
    best = 5
    average (normalized to 5.0 scale) = 4.0
    average = 4.0
    count = 1
    Warning: If count is specified in review aggregate, page should contain reviews. Otherwise you may want to use votes.

    Plugin Author Milan Petrovic

    (@gdragon)

    This is fixed now, and available in 1.9.14 version.

    Thanks Milan, issue #2 is indeed fixed but would you mind helping out with issue #1 as well?

    Issue #1
    If I visit the settings page and navigate to the special tab I see that in the Google Rich Snippets section the following is selected: Snippet will be rendered hidden on the page (style display set to none).

    If I uncheck that, Google will no longer complain but every visitor sees the Rich Snippet text.

    Any solution for this issue? How are other people dealing with this?

    Plugin Author Milan Petrovic

    (@gdragon)

    That is the way snippet work. While back it was working even when hidden, but about year and a half ago, Google made changes demanding that snippet is visible, or it will be ignored by the search engine. What I did with my xScape Theme Framework is I added it to the page but with small impact to the visibility. There is a hook that you can use to add it anywhere in the page, so try to find some place with least exposure.

    ah, I understand. thanks for clarifying that.

    ahm, my theme also has plenty of hooks can you help me out with the php function I need to manually display the rich snippets?

    ok, forget this question, I found the section about inserting 🙂

    Hi, i have the same problem. I don’t understand exactly what to do to get this google problem solved. I have now following code in my single.php:
    echo wp_gdsr_render_article(10, false);

    But this seems not to help. What exactly do i need to do?

    Hide text and show only animation image.

    Finally i found the solution to this problem.

    Visit:
    gdstart rating plugin > setting > special (tab the last tab on the page)

    there , uncheck this option saying “Snippet will be renedered hidden on the page (style display set to none).”

    i tried this on my blog eyuva it worked out.

    now my snippets are ok on the test tool but google doesn’t want to show my evemilano stars in SERP 🙂

    techaddict thank you your answer this helped me out !!!!!!!!

    gioz80 same to me with my website filme hd dosent appear in serp but if i`m cheking with tools it works -.-

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: GD Star Rating] question regarding the implementation of microformats’ is closed to new replies.