WordPress.org

Support

Support » Plugins and Hacks » [Plugin: GD Star Rating] Problem with rich snippet, not showing in Google

[Plugin: GD Star Rating] Problem with rich snippet, not showing in Google

  • LuboUzunov

    @lubouzunov

    I tried this solution by pmagony, but it’s doesn’t work for me 🙁 It’s been two weeks and still nothing in Google.

    I was able to resolve this issue by modifying GD Star Rating code.

    They have a major flaw in their design, in which they “hide” the snippet data with inline CSS. Google doesn’t like this and therefore doesn’t render the ratings.

    Here’s how you fix it:
    MAKE A COPY OF THIS FILE BEFORE YOU EDIT IT!
    Open: /plugins/gd-star-rating/gdragon/gd_google.php
    Edit the following line numbers 89 & 149 from:

    $hidden = $options[“hidden”] ? ‘ style=”display: none !important;”‘ : ”;

    TO:

    $hidden = $options[“hidden”] ? ‘ style=”position:absolute;left:-9999999px;”‘ : ”;

    Save, upload, sit tight for 24 hours and Google will start showing your rating inline with your results.

    With this changes, in Google “Rich Snippets Testing Tool” is fine, but in the search… the stars are not showing. /try with this page -> Rich Snippets Testing Tool/.

    What can I do? Any other solutions?

    My blog: http://bbcitylights.netau.net/
    ver.: 3.4.1

    http://wordpress.org/extend/plugins/gd-star-rating/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I tried your fix but nothing shows up on Rich Snippets Testing Tool anyway… did you manage to find a solution?

    same problem
    http://hatzak.de doesnt help for me either 🙁

    So now I know what the problem is but”settings” special” Section.
    Anyways… if i Change the settings I am not able to solve it.

    Its gone but also http://www.google.com/webmasters/tools/richsnippets google does not reognize it anymore when I set it to “on snippet action” or “Automatically Embed Google Rich Snippets.” disable

    It is the “Google Rich Snippet” which can be edited in the
    in the readme I found this

    ” = Plugin displays in the post content weird string that includes post title and rating. What is that? =
    Most likely it is Google Rich Snippet. More info on that: http://dv4p.com/wh. To disable it, hide it or set it differently use tab Special on the Settings panel.”

    ah no other way round. google shows but it also shows on the website 🙁 double e

    Bewertung: 5.0/5 (2 votes )
    1Onlinemarketing Beratung, 5.0 out of 5 based on 2 ratings

    the second line is for google but i wanna hide it

    @onlinemarketing-berlin
    Sounds like you want to hide the ” Article Title, 8.8 out of 10 based on 9 ratings ” string??
    The plugin code was changed last year to display this text, which fixed the bug reported by @lubouzunov in this thread where Google wasn’t showing the ratings in Rich Snippets

    If you really want to hide the text Add this to your style.css or custom-style.css file.

    .hreview-aggregate
    {display: none;}

    You don’t want to hide this – Google is likely to stop displaying the rich snippet if you do. Here’s more info tech.graphicline.co.za/gd-star-text-after-article and a better way to handle this.

    i am having same issue on my website ( Dramas Online ), Please Help!

    how to solve that kind of problem, i think the GD star rating is not compatible with wordpress…

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: GD Star Rating] Problem with rich snippet, not showing in Google’ is closed to new replies.