WordPress.org

Forums

FV WordPress Flowplayer
[resolved] Fatal error with latest version (7 posts)

  1. spidermann
    Member
    Posted 4 years ago #

    Updated to the latest version, which fixed the playback issue, but has introduced a new one.

    This is on a site with a good amount of other plug-ins, but it is the only site to show this error:

    Fatal error: Class 'flowplayer_frontend' not found in /home/******/public_html/wp-content/plugins/fv-wordpress-flowplayer/controller/shortcodes.php on line 33

    http://wordpress.org/extend/plugins/fv-wordpress-flowplayer/

  2. FolioVision
    Member
    Plugin Author

    Posted 4 years ago #

    Hi Spidermann,

    We've fixed this issue as well. We did a lot of improvements last month:

    • adding video upload
    • redirects after the video
    • shortcode API compliance

    WordPress 3.0 just happened to come out at the same time. A perfect storm, if you will. It took some time to reconcile all of the improvements and WordPress 3.0 to get things back to FV reliability. The older versions (easily downloadable at WordPress.org) did continue to work throughout though (without the new features).

    We will be more careful with experimental versions going forward (we don't like to keep multiple versions open as it slows down development). We'll introduce one feature at a time.

    Thanks for your help. As you know it's faster to submit bug reports and feature requests at our FV WordPress Flowplayer page.

    Thanks!

    Alec

  3. FolioVision
    Member
    Plugin Author

    Posted 4 years ago #

    If anyone is still occasionally having trouble with this issue, you might want to update one line in the shortcodes.php file.

    Thanks.

  4. rstaufer
    Member
    Posted 4 years ago #

    I have WordPress 3.0.3 and FV Flowplayer 1.2.2 on two sites.
    On one site the Flowplayer works successfully. On the other, it can
    not be activated because of this error message:

    fatal error: Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/content/26/6408726/html/wp-content/plugins/fv-wordpress-flowplayer/models/flowplayer.php on line 4

    The installation on the first site was two weeks ago. The second one with the error was yesterday. Can you advise?

    Thanks

  5. FolioVision
    Member
    Plugin Author

    Posted 4 years ago #

    Hi rstaufer,

    this sounds exactly like our FAQ #1, please check the PHP version on your server.
    Thanks,
    Zdenka

  6. rstaufer
    Member
    Posted 4 years ago #

    Thanks.

    My web host, GoDaddy, is running php 4.x! I asked them to upgrade.

    Robbie

  7. FolioVision
    Member
    Plugin Author

    Posted 4 years ago #

    Hi rstaufer and other FV plugin fans,

    Support for our FV plugins is on our own site. In this case at FV WordPress Flowplayer.

    Thanks for using Foliovision's FV plugins!

    Making the web work for you, Alec Kinnear

    PS. Expert installs of any of our FV Plugins are also available as a done-for-you service.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • FV WordPress Flowplayer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic