Support » Plugins and Hacks » Plugin: Fuzzy recent posts

Viewing 15 replies - 1 through 15 (of 25 total)
  • Hi!

    I’ve got Fuzzy recent posts up and running. Can you tell me how I can make the list look like the sidebar display of recent posts on Blogger? Right now the date is diplayed above the post and this kind of stretches the length of the list. How can I modify what is echoed?

    Thanks in advance.

    Cheers,
    Navin

    well, you can do so in two ways:

    either you find and replace the line:

    $output .= "<h3>$post_date:</h3>n<ul>n";

    with:

    $output .= "<ul>n";

    Alternatively, call:

    $recent_posts = $sem_recent_posts(‘display=xml’);

    $recent_posts will then contain raw xml data, as documented. from there, you can format it any way you like with xslt.

    Cool! The first method worked very well for me!

    Check it out here: http://vidya.sigamany.com/blog

    Thanks Denis-de-Bernardy!

    Dude, how to take the RSS feed thing off the output? I tried taking out the inside parts of (‘RSS Feed’) but got an error.

    @paula remove lines 205-210, immediately before echo $output;

    That’s what I thought. But was afraid to because of references earlier up the code. I have seen far too many parse errors and other oopsy lines lately after mucking with plugins that my eyes were beginning to hurt.

    Anyway, it worked. Thanks!

    Stay tuned, too, as v3 is coming very soon. it features an xslt argument, that will let you use any custom template that you want.

    I’ve released version 3.0 beta of the plugin. Testers are welcome.

    The two new key features are:

    – XSLT argument: customize the tile any way you want
    – Built-in caching

    there’s a last minute bug fix. sorry about that. 😉

    i’d be curious to know the proportion of folks who cannot use xslt…

    I’d imagine quite a few =)

    I’ve upgraded to the latest version and the fuzzy plugins do not render properly. I get the message about contacting my host about the problem. I emailed support and got the following reply …
    “Dom XSLT” php module is already pre-compiled with our apache server. What do I do now?

    not properly then, since the plugin checks for the xslt functions’ existence. i suggest you direct them to the xslt page i point to from the plugin’s error message. likely is that sablotron is missing or something — the page contains install and config information.

    re removing RSS feed in version 3? What lines to remove please?

    just set the field name to nothing, e.g.

    sem_recent_posts(‘feed_name=’);

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Plugin: Fuzzy recent posts’ is closed to new replies.