Support » Plugin: FT Calendar » [Plugin: FT Calendar] Calendar Is Inoperable

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi, I am having a similar problem, when I click on arrow to change month the calendar does nothing (both thumb and large). First noticed this a week ago, but not sure if it was happening before as I didn’t entered November events until last week. Tried to deactivate other plugins and no lucky. The only way it works is if the theme slider (s3slider) is not activated and no jQuery loaded. Can anyone help me with that?

    It sounds like a jQuery/Javascript problem. Do you have any caching plugins running that might be minifying the JavaScript?


    hi Layotte, thanks for replying, how do I check this? Below is list of scripts in the head of my frontpage ( Seems that Contact Form 7 is caching a global variable, but I don’t know if it has something to do with your question. Besides that, my theme inserts the script for s3slider in the body, not copied here. I was trying to make sure that jQuery is properly loaded, and that all javascript that require jQuery are properly enqueued with this dependency stated – it seems to be the case for all of the activated plugins but I haven’t checked Contact Form 7 yet.

    [Code moderated as per the Forum Rules. Please use the pastebin]

    hi, sorry, got moderated for the html code, here it goes at pastebin:

    hi again, my theme uses Quick Cache plugin, but I don’t use any minifying plugin

    Try disabling Quick Cache and see if it works without it. I’ve never used it, but it might be auto-minifying the JavaScript or screwing up something else.


    hi layotte, disabled quick cache but no difference. Quick Cache doesn’t compress script unless you change some settings at server side, which is not our case. But, anyway, disabled that and had no changes. When I first noticed this problem I thought it would be a conflict with another plugin, so I checked to make sure that all my plugins are correctly loading jQuery using wp_enqueue_script. That seems to be the case. The far I could go with Firebug was to that bit of code below: one of these 2 functions are not responding correctly, but I don’t know which is the one ($.post() or $.replaceWith()). Could it be that FT Calendar is not relying upon jQuery library for any of these 2 functions?, data, function(response) {
    $( ‘div.ftlargecalendar’ ).replaceWith( response );

    sorry, to be more precise, this code is from single-post-page-shorts.js, lines 25 or 48 (depending on the type of calendar, large or thumb)

    What error is firebug reporting?

    Works fine for me here:


    hi lew, it doesn’t fire any error message, it simply doesn’t change. at the firebug console it shows a call to POST: tabs headers and post are ok, filled with data, but, tabs response and html are empty. Therefore, either jQuery.Post is not getting the response from the db, or it gets and jQuery.replaceWith is not being able to accomplish the replacement of content.

    As I said at the beginning, if I prevent my theme and plugins to load jQuery, it works (the calendar changes when I click next month), but otherwise it stays frozen when I clieck. When the calendar is working then it is my slideshow (s3slider from my theme) that stops working. So, I believe it is a conflicted call to jQuery or something like that.

    after reading some articles on “ajax post failing silently” it seems that jQuery.Post is indeed failing silently. Looks like I would have to rewrite the code to find out the actual error, by replacing .post() for .ajax(). Could you help with that so then I can bring more info on the error?

    now you guys from FT need to reply 🙂 I have changed the call to in single-post-page-shorts.js for a call to jquery.ajax(), in order to trigger an error and parse the information. But, I mistyped a “;” after the errorFunction. Firebug console told me that 😉 But, surprisingly, the calendar works again. If I correct the mistyped ; then it displays an alert for error and doesn’t change the month. Here goes the code I replaced:

    /*, data, function(response) {
    			$( 'div.ftlargecalendar' ).replaceWith( response );
    		}); */
        		url: FTCajax.ajaxurl,
        		type: "POST",
        		data: data,
        		success: function(response) {
    			$( 'div.ftlargecalendar' ).replaceWith( response );
        		error: alert('failure');

    Not only the code with the mistyped ; corrects the change in large-calendar, it also corrects the change in thumb-calendar. Have no idea why. Any thoughts?

    more on that: the calendar changes but it is the entire webpage that is loaded (not only the calendar, so ajax is not working). Also the popup with the events in the day that comes from the thumb-calendar is not showing, so basically ajax is not working anymore (which makes sense if there is a syntax error). Therefore, definitely, jQuery.Post is failing in my website when called by FTCalendar. Need some help to fix it please.

    SOLVED, I apologize, here it goes the problem: I have 2 domain names pointing to the same space and I was using 1 for the public side and another for the /wp. Ajax takes it as a violation of same origin policy. Changed in WordPress settings and it is now working. Thank you for your patience and help, I believe that just by having someone to talk to helped me to search better, so it is really appreciated 🙂

    If anytime anyone lands in this thread, please do not consider the change of code (post() X ajax()) unless you are debugging your code. For more on that, check this article (some pros and cons of using ajax()instead of post() for debugging).

    I have spent 1 week searching for the problem in the wrong direction. During this time I had to dig into FT Calendar code, and research a lot on plugin conflicts. To my understanding this plugin is very well coded and follows all the good coding practices that are normally recommended. A very precious piece of software for those in need of calendar features such as recurring events. Many thanks to FT guys for that.

    Glad you got it working! Thanks for sharing the solution!


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: FT Calendar] Calendar Is Inoperable’ is closed to new replies.