WordPress.org

Forums

Frontend Uploader
[resolved] Problem with the form placement in articles (7 posts)

  1. dapickboy
    Member
    Posted 2 years ago #

    Hi !
    I've tried the shortcode on a sidebar, it worked perfectly.
    But now I want to use it inside an article, and the form is always processed before my text. i.e I can't get the form right in the middle of my text. It always gets just after the title.
    Does someone have some clue on this ?
    Thx.

    http://wordpress.org/extend/plugins/frontend-uploader/

  2. dapickboy
    Member
    Posted 2 years ago #

    I dug a little, and it seems that the problem comes from 'echoing' inside a shortcode function instead of 'returning'.

    http://wordpress.org/support/topic/shortcode-output-always-appearing-at-top-of-page-content

    Basically, I understand what it means, but I can't seem to hack the plug right...
    Please, could someone have a look at it ?

  3. Daniel Bachhuber
    Hand Built
    Plugin Contributor

    Posted 2 years ago #

    Nice debugging! That's exactly the case. I've filed an issue for it; hopefully there will be a fix out soon.

  4. Rinat Khaziev
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks dapickboy,

    I'm gonna fix that in the next minor release

  5. dapickboy
    Member
    Posted 2 years ago #

    Can't wait ! ;)

  6. socialpyramid
    Member
    Posted 2 years ago #

    I have the same problem! It would be awesome to be able to put some text or photos before the form.
    Thanks

  7. Rinat Khaziev
    Member
    Plugin Author

    Posted 2 years ago #

    This is taken care of in the new release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Frontend Uploader
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic