WordPress.org

Support

Support » Plugins and Hacks » Front End Upload » [Plugin: Front End Upload] Fails to upload files but no error message

[Plugin: Front End Upload] Fails to upload files but no error message

  • For some reason, although this plugin used to work perfectly, everytime I upload a file, although I can see the progress of the file being uploaded, and I get the “upload successful” message, there is no link in the email, and no files on the server (even though it takes a long time to “upload” a large file, so seemingly, it’s going somewhere). I have this problem in both chrome and firefox. I’m also using Front End Uploader Pro.

    Thanks!

    http://wordpress.org/extend/plugins/front-end-upload/

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’ve noted the same problem beezwings

    im having the same problem, started a week ago.

    I noticed that if your uploaded image extension is JPG in uppercase it will not work.

    It was happening for all kinds of files for me. The problem still remains…a little frustrating, since I bought the pro version too.

    I have noticed this also but only with IE so far. Bit annoying forcing users to upload photos via a specific browser. I might have a look at the code and see if I can find a fix. If I do I will post it here.

    Did anyone have any luck with this? Same exact thing happened to me. Worked great until about 9/8.

    The problem is with the referrer validation that was added. It’s on lines 113-122 in the /front-end-upload-pro/upload.php file. Commenting it out makes it work again. But disabling that is obviously no good. Trying to figure out how to fix it now. Will post an answer when (if) I get it.

    Wow! Thanks for finding that. It works again! What is referrer validation? My site is an internal site for 7 people; is that validation still necessary? Obviously, an all-inclusive fix would be best, but just wondering if it’s absolutely necessary….

    This is still not working?!

    @thandrol – I’m using the none-pro version. So the codelines is properly not the same. So what exactly have you commented out to make it work?

    Plugin Contributor Jonathan Christopher

    @jchristopher

    Hi all, thank you very much for the diagnosis — it looks like there is an issue with referrer validation when using the Flash runtime since the referrer isn’t what is technically expected. I’ll see if I can dig around a bit more.

    Thanks Jonathan! I hope you can fix it; I would be so happy if this plugin could work again!

    @daller, i just did this and it worked. below is the code i commented out.

    /*
     * Validate the referer
     */
    // $salt = get_option( 'feuprosalt' );
    // if( empty( $_SERVER['HTTP_REFERER'] ) || false === get_transient( 'feupro_referer_' . md5( $_SERVER['HTTP_REFERER'] . $salt ) ) )
    // {
    //    if( isset( $settings->debug ) ) Log::write( 'info', 'Failed referer verification' );
    //    die();
    // }
    // if( isset( $settings->debug ) ) Log::write( 'info', 'Passed referer' );
    beezwings

    @beezwings

    @infogeniuz, I’m a noob (and I’m trying to use the pro version)…can you tell me which file this is in, thanks!

    Hi Jonathan, Great plugin.
    Same issue with IE-9 with the “Front End Upload” version 0.6.1.
    It likes to upload files, but no directory creation on the server and uploading files.

    Comment out line 78-79 in the file destination.php and it works again.
    (I don’t understand exactly wat this test does….).

    /*
    if( empty( $_SERVER['HTTP_REFERER'] ) || false === get_transient( 'feu_referer_' . md5( $_SERVER['HTTP_REFERER'] . $hash . $salt ) ) )
        die();
    */
Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Front End Upload] Fails to upload files but no error message’ is closed to new replies.
Skip to toolbar