WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Front-end Editor] wp 3.0

[Plugin: Front-end Editor] wp 3.0

  • Hi Scribu!

    Clean WP 3.0 RC3, using default theme and logged in as admin…

    With FEE 1.8 I can’t edit text widgets at all (they don’t even get highlighted)…

    With FEE 1.9a they get highlighted and are editable BUT only in plain mode… no editor shows up (while in articles etc… it loads).

    Any ideas? Thanks!

    http://wordpress.org/extend/plugins/front-end-editor/

Viewing 15 replies - 1 through 15 (of 21 total)
  • …and I just tried to edit a couple of text widgets (with 1.9a) but after saving the modifications they disappeared! i checked in the back-end and the widgets are still there, but the title and the content are empty!

    Try the latest development version (1.9-alpha).

    Thank you for the prompt reply.

    The latest dev still doesn’t work… Areas become editable but the WYSIWYG editor doesn’t load for text widgets (like the previous dev version)… And if I make some edit with the plain editor and save, the text widget is completely erased.

    I’m on WAMP local server and WP 3.0 RC3, default template.

    The editor loads and works well only for article editing.

    Does it work on your side? Could it be the default theme the problem?

    The rich editor isn’t enabled for text widgets currently.

    Yes, it works for me on all widgets.

    Are you using the old Kubrick theme or the new twentyten?

    I’m using the new twentyten and 5 text widgets…
    So I won’t be able to use FEE’s wysiwyg editor for those widgets?

    Ah, I think you got an older version of the main javascript file. Try the latest development version (1.9-alpha2).

    🙁 Nothing to do Scribu!

    The editor works fine for article content, but when i double-click text widgets it doesn’t load properly… only plain editing with “destruction” of the widget if i press Save.

    Any other ideas? Is it only me or can someone else confirm this bug?

    What happens if you try to edit other widget types?

    Try disabling all other plugins (if you have any).

    Had an error in the script. Development version is now 1.9-alpha3.

    Trying alpha3 (disabled ALL plugins)…

    Same problems: NicEdit doesn’t load and widgets get content destroyed once i press Save (50% of the times, it’s random…)

    I tried with other default widgets and i can edit their options, but editing of the content has the same problems.

    Please, check these screenshots:

    This is ok, editing an article: http://img696.imageshack.us/img696/1296/57804582.jpg

    This is NOT, editing a widget: http://img683.imageshack.us/img683/9031/88012964.jpg

    As I’ve said, NicEdit is not enabled on text widgets, at least not in version 1.9 (which is due for release any day now).

    What I’m trying to figure out here is why the widget content is destroyed.

    Could you make an admin account for me on that site so I can take a look for myself? My email: scribu@gmail.com

    Oh, I’d like to make an account for you, but I’m working on a local server. If you want I could find a free hosting for some tests… but then I don’t know if we can replicate the same problems…

    Text widgets editing is VERY important for me, why did you disable this possibility? 🙁

    You misunderstood:

    Text widget editing is still possible, only that a plain textarea is used instead of NicEdit.

    I will probably bring back NicEdit to text widgets in a future version, since it requires some significant modifications to get it right.

    Make it plus one for nicedit on text widgets.
    I was surprised to find it gone after upgrading to fee 1.9 today. 🙁

    I too would love to see the addition of NiceEdit for editing text widgets. Until you get the time to do this……. do you know of any text widgets that have an embedded editor ? Thanks.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: Front-end Editor] wp 3.0’ is closed to new replies.
Skip to toolbar