Front-end Editor
[resolved] Problem with saving the_terms (2 posts)

  1. ouranos2
    Posted 5 years ago #

    Hi Scribu,

    I can't save the terms by editing the field of a custom taxonomy. Here is the code in the template : <?php the_terms( $post->ID, 'action', '', ', ', ' ' ); ?>

    I can edit the field, enter or change the terms, but when i try to save, it doesn't work. Strange thing, doing that, the "empty" word is changing into "vide" (french for empty).

    No problem with the other fields so far.

    I just tried Taxonomy drill-down ... Quite a good idea ! I was looking for a way to dynamically use custom taxonomies, your plugin is perfect for that !
    Bravo !

  2. ouranos2
    Posted 5 years ago #

    Ok, I'm answering to myself ...
    I faced the same problem this user described a while ago.

    There is a problem with the hierarchical parameter of custom taxonomies. I changed hierarchical from "true" to "false" :

    function build_taxonomies() {
    register_taxonomy( 'action', 'post', array( 'hierarchical' => false, 'label' => 'Action', 'query_var' => true, 'rewrite' => true ) );

    and my problem was solved. I can now save my terms after editing.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Front-end Editor
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic