WordPress.org

Support

Support » Plugins and Hacks » Front-end Editor » [Plugin: Front-end Editor] I can't make fee_inject_dummy_post work correctly

[Plugin: Front-end Editor] I can't make fee_inject_dummy_post work correctly

  • Hi,

    Thank you for an amazing plugin.

    I am trying to create an “add new” page. I created a custom template exactly as below, but it doesn’t work.

    Also, I want to add in the content field, and two custom fields which are named Subtitle and Tab.

    If you could please point me in the right direction, I’d appreciate it.

    /**
     * Blog Template
       Template Name: Add new card
     */
    ?>
    <?php get_header(); ?>
    <?php fee_inject_dummy_post( 'card', false ); ?>
    <?php while ( have_posts() ) : the_post(); ?>
    	<article id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    		<h1><?php the_title(); ?></h1>
    	</article>
    <?php endwhile; ?>
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    http://wordpress.org/extend/plugins/front-end-editor/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author scribu

    @scribu

    Please describe “it doesn’t work”. Any JavaScript errors?

    What happens is I get a page come up with a title, but then when I edit and then save, it doesn’t create a new post (post type is card). It just saves the title on the existing page.

    https://www.3x5db.com/

    click log in, demo, demo.123 (author roll)

    click New in the header menu (under the S in Responsive)

    edit and save the title at the top of the page itself (which says “test post from front end”).

    then click All Cards. The new card won’t be there.

    If you add a card from the back end, it does save, and it does show up under All Cards

    So, when you edit and save the title, it saves it on that page, but it doesn’t add a new post.

    I can give you an admin password if you’d like. My email is mike at miketurco com, drop me a line if you need that.

    Thank you,

    Mike

    Plugin Author scribu

    @scribu

    You need to check the “Edit all post fields at once.” box in WP Admin -> Settings -> Front-end Editor.

    When I do that I get a 404 error. I tried that last night & again just now to double check. I left things setup that way, now. So if you try to create a post you’ll see the error. Also, the post does not save. Thanks.

    I see this has been marked as resolved… maybe I clicked that by accident?

    Plugin Author scribu

    @scribu

    That’s weird. My hunch is that it’s some other code from a plugin or theme messing with it.

    I see this has been marked as resolved… maybe I clicked that by accident?

    No, I did (and undid it now).

    I deactivated all plugins except Custom Content Type Manager http://wordpress.org/extend/plugins/custom-content-type-manager/ . When I disable that, I lose my custom post type all together, and your plugin stops working as well. (Which makes sense, as the post type I’m trying to edit disappears.)

    Sounds like I need to find another way to add custom post types and fields. If you know of a plugin that is compatible with your system, I’d appreciate it if you could mention that. If not, I’ll take the long road. (I am just learning php.)

    Either way, your plugin is really slick and I like it a lot. I also appreciate your contribution of this to the public.

    Mike

    Plugin Author scribu

    @scribu

    You should try a code generator:

    http://themergency.com/generators/wordpress-custom-post-types/

    though I’d be really surprised if the problem was the Custom Content Type Manager plugin.

    Maybe a piece of code or some such thing got left behind from another plugin. Or maybe its the theme itself in some way. I’ll try with a fresh install and see what happens.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Front-end Editor] I can't make fee_inject_dummy_post work correctly’ is closed to new replies.
Skip to toolbar