Support » Plugins and Hacks » Front-end Editor » [Plugin: Front-end Editor] Custom taxonomy term editing doesn't work

[Plugin: Front-end Editor] Custom taxonomy term editing doesn't work

  • Custom taxonomy term editing is not working on my site, though all other FEE features work fine.

    I have followed the Wiki as closely as possible and am using the blessed the_terms() function to display terms. Terms display fine, but no FEE edit button appears when I mouse over them. All other FEE edit buttons on the page (and in the same div) work perfectly—just none of the custom taxonomies. Here is my code:

    <div class="admin-only">
    Custom field 1: <?php echo editable_post_meta( get_the_id(), 'cf1', 'input'); ?> <br>
    Custom field 2: <?php echo editable_post_meta( get_the_id(), 'cf2', 'input'); ?><br>
    Pub code: <?php echo editable_post_meta( get_the_id(), 'cf3', 'input'); ?>	<br>
    People: <?php the_terms( get_the_id(), 'people', $before, ' | ', $after ); ?> <br>
    Issues: <?php the_terms( get_the_id(), 'issue', $before, ' | ', $after ); ?> <br>
    Type: <?php the_terms( get_the_id(), 'type', $before, ' | ', $after ); ?> <br>

    I tried putting each entry in a div, with no effect. I also tried using $post->id instead of get_the_id(), with no effect.

    Why won’t this work?

    This happens on my WP 3.2.1 site using FEE 2.1.2 and 2.1.3.


Viewing 3 replies - 1 through 3 (of 3 total)
  • I figured out that the problem is coming from the fee_choose_taxonomy_interface function that is supposed to set which term interface to use, dropdown or autosuggest.

    I copied this code straight from https://github.com/scribu/wp-front-end-editor/wiki/Editing-taxonomies into my functions.php:

    function fee_choose_taxonomy_interface( $data ) {
      if ( isset( $data['taxonomy'] ) )
        $data['type'] = 'terminput';
      return $data;
    add_filter( 'front_end_editor_wrap', 'fee_choose_taxonomy_interface' );

    Including that code causes term editing to stop working—i.e., no Edit link appears when you hover over the terms. It only breaks if the type is set to 'terminput'. If the type is 'termselect', it works fine.

    So: is there something wrong with terminput? These are hierarchical taxonomies.

    Plugin Author scribu


    Try the development version (2.2-alpha3).

    With 2.2-alpha3 the input field works, but it’s just a plain text field – auto-suggest is not working. The console shows 2x of this error:

    TypeError: 'undefined' is not a function (evaluating 'this.input.suggest')

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Front-end Editor] Custom taxonomy term editing doesn't work’ is closed to new replies.
Skip to toolbar