Support » Plugin: Front-end Editor » [Plugin: Front-end Editor] Blog title on 1.9.2

  • After I upgraded to 1.9.2, my blog-title code becomes garbled and repeated twice.

    I deactivate “Site title and description” and the problem is resolve.

    Any suggestions?

    <div id="blog-title">
    <span>
    <a title="<span data-type=" href="http://compasscommons.net/">Compass Commons</a>
    </span>
    <a title="<span data-type=" href="http://compasscommons.net/">" rel="home"><span class="fee-field fee-filter-bloginfo" data-show="name" data-type="input">Compass Commons
    </span>
    </a>
    </div>
Viewing 7 replies - 1 through 7 (of 7 total)
  • I am having problems as well, but it is on a dev-blog using 3.1, so I am happy (I should say relieved) to see others having issues.

    As best I can tell, there is a search/append function that looks for the post title and wraps it with <span>…</span> to assist the javascript.

    The problem is that the theme I have activated uses the post title as the image title and alternate text in addition to the headline.

    Here is a small example:

    <h3><a href="http://candy95.aggielandsrock.com/2010/11/beauty-and-the-beast-on-broadway/">
    <!-- first occurance of FEE <span> -->
    <span data-type="input" data-post_id="199" class="fee-field fee-filter-the_title">Beauty and the Beast on BROADWAY!</span></a></h3>
    
    <div class="post-date">Tuesday, November 23rd, 2010</div> 
    
    <div class="post-tnail"><a href="http://candy95.aggielandsrock.com/2010/11/beauty-and-the-beast-on-broadway/"
    <!-- second occurance of FEE <span> -->
    title="<span data-type="input" data-post_id="199" class="fee-field fee-filter-the_title">Beauty and the Beast on BROADWAY!</span>"><img src="http://candy95.aggielandsrock.com/wp-content/themes/imperial/thumb.php?src=http://candy95.aggielandsrock.com/wp-content/uploads/2010/11/beauty-beast.jpg&w=372&h=100&zc=1&q=95"
    <!-- third occurance of FEE <span> -->
    alt="<span data-type="input" data-post_id="199" class="fee-field fee-filter-the_title">Beauty and the Beast on BROADWAY!</span>" /></a></div>

    The first comment is near the intention of the plugin, but the latter two are collateral damage due to my themes author using the post title instead of any other meta info.

    Look forward to the next update so I can use this again. I really like where it is headed.

    Patrick

    EDIT: Formatting

    Yes, I think there is simply a misformatted quotation mark or span tag that is throwing off what follows.

    Plugin Author scribu

    (@scribu)

    Unfortunately, there is no way for the plugin to know when a template tag is called as a HTML attribute or not. This is not something new in version 1.9.2.

    You can try removing the span, like this:

    echo strip_tags(get_bloginfo('title'));

    Good point. I just hadn’t noticed this until the update. Maybe it’s always been there.

    Scribu, how would I use your code? Is that a change to the plugin or functions.php? (I’m using Thematic.)

    Plugin Author scribu

    (@scribu)

    functions.php. I’m not very familiar with Thematic, so I can’t tell you more.

    Thank you. I’ll check in over there.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Front-end Editor] Blog title on 1.9.2’ is closed to new replies.