Support » Plugin: FoxyShop » [Plugin: FoxyShop] Datafeed script throws error

  • Resolved Jacob Dubail


    Hey David and anyone else reading this,

    Here’s a post I posted at the Foxycart forum that I’d like to post here as well as the error is more WP-based:

    I’m using the latest versions of WP, Foxyshop and Foxycart.

    I’m using the datafeed endpoint script from the Foxyshop files.

    I’m feeding the datafeed to my 3rd party script that fires off a really nasty SOAP call (which I’ve tested outside of the datafeed functionality).

    When I make a purchase or feed the datafeed, I get a really strange error. WordPress acts like it isn’t installed and a wp-config.php file doesn’t exist. Here’s the body of the email that Foxyshop’s error handling fires off:

    A FoxyCart datafeed error was encountered at January 23, 2012, 4:41 pm.

    The feed that failed was

    The error is listed below:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    I cannot figure out why the script is running the WordPress installer. I can access the datafeed scripts correctly from the browser and have even given them read/write access (777) temporarily.

    Any idea what would be causing this?

    Thanks for looking.


Viewing 1 replies (of 1 total)
  • Plugin Author sparkweb


    So just to close the loop on this one, Jacob tried using the FoxyCart interceptor too and that didn’t work. Then he linked directly to the third-party script and that worked fine. This script has worked well other places so we’re blaming it on GoDaddy hosting and just rolled the other script into the main datafeed.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: FoxyShop] Datafeed script throws error’ is closed to new replies.