Support » Plugin: Foursquare Venue » [Plugin: Foursquare Venue] Foursquare venue has stopped working

  • Plugin has been working fine for weeks, now it’s suddenly broken :/
    I’m getting a connect() timed out! error

    Has something been changed on the part of Foursquare in the way you have to call their API maybe ?

    Maybe not the issue here , but when I run the API call separately (taken from foursquare-venue.php in the plugin dir) I get this warning “meta”:{“code”:200,”errorType”:”deprecated”,”errorDetail”:”Please provide an API version to avoid future errors. (followed by all the data that I need …)

    So , not sure why my wp_remote_get of the Foursquare API url is timing out on me all of a sudden :/

    (I even tried upping the timeout value in the wp_remote_get array to 120 , but still get an error back …

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Sutherland Boswell


    Strange, it still seems to work in my tests but it does look like a version parameter is now needed to avoid errors. Can you try changing
    $request = "$id?client_id=$client_id&client_secret=$client_secret";
    $request = "$id?client_id=$client_id&client_secret=$client_secret&v=20111113";

    Like you said though, that may just be a coincidence. The timeout seems like a more basic problem of the server being unable to reach foursquare.

    thanks so much for your quick reply, altho it still throws a timeout.
    BUT after some further testing (could/should have done that before posting here to avoid confusion) it seems I only get the timeout on 1 server.

    Took the code to another server and it works fine … damn… gonna have to move everything I guess :/

    Just an update. and yes, it really took 6 days for my hosting provider to admit that the error was on their side.
    Still not sure what it was. I even had a Foursquare API dev look at the problem (and being very helpfull at it).

    just adding the &v=20111113 parameter to the API call however throws an error (and doesn’t return any data)

    works fine (don’t know for how long) without the v – parameter tho.

    Any thoughts on that ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Foursquare Venue] Foursquare venue has stopped working’ is closed to new replies.