Support » Plugin: Fotobook » [Plugin: Fotobook] There are no albums text appears above header

Viewing 4 replies - 1 through 4 (of 4 total)
  • Just by chance are you able to import your photos correctly? I’m having the same issue only it’s with albums that aren’t pulling in photos properly and shows 2 lines of the text for me.

    I’m thinking it’s definitely something along the lines of the custom theme is using a hook that fotobook is also using and possibly may be screwing with queries of some sort.

    Also, if you have access to your database – if there aren’t any photos showing on your site. Look inside the database to see if they properly pulled into the database. If they’re in the database and not showing up on your page, it’s most definitely a mysql_query hook conflicting.

    Let me know if this helps as I’m troubleshooting myself as well. If I come across a solution for this I will obviously let you know as well.


    Thanks for this Ryan

    I will have a look at this and let you know.

    Hi guys,

    This bug is due to recent changes to the Facebook API. More specifically in concerning Fotobook among similar affected apps, as of the 1st of August 2012 the ‘prompt_permission’ endpoint(among others) has been deprecated, as described in the link below.

    Fotobook can access and get permissions regarding ‘Basic Info’ which seem to be done in Step 1 of the Fotobook Account Setup, but it fails at getting the ‘photo’ and ‘video’ access permissions which is attempted in Step 2. Hence the error you see on Facebook when attempting to complete Step 2 ‘Request Permissions’ using WordPress Fotobook in the Fotobook Settings/Setup page:

    ERROR: This endpoint has been deprecated. To temporarily reenable it, you may disable the “august_2012” platform migration. It will be disabled permanently on August 1, 2012.

    I finally figured out a fix for this myself, based on the new way of requesting permissions using the Facebook API, described in the link below:

    Ideally, the changes should be implemented in the Fotobook Code, but given certain legal implications I’m not sure how feasible that would be, unless permission is granted by the Fotobook owner/developer.

    However, You CAN work-around this without getting into the code.

    Here is the Solution:
    Note: You might have to first remove your Facebook account from Fotobook, as well as remove the Fotobook App from Facebook, before you attempt the solution.

    1)Install latest version of Fotobook on your WordPress Host, making sure it has PHP 5

    2)Under Settings -> Fotobook in wordpress, Complete ‘Step 1’ of Facebook Account Authentication, closing the popup window when requested by the message displayed.

    3)Press ‘Step 2: Request Permissions’ button, which should take you to the Facebook popup with the deprecation Error. Close this popup window and immediately open a new tab in your browser. Paste the following url into the address bar of the new tab and press enter (I presume client_id and app_id are the same for you guys, since they correspond to Fotobook ID):,user_photos,user_photo_video_tags

    4)You should now be able to allow Fotobook permissions to access your Facebook photos and videos by pressing allow.

    5)Go back to WordPress Settings -> Fotobook and complete the Facebook account setup by clicking on ‘Step3: Apply Permissions’ button.

    6)You should now be able to Import the Albums from your account, as expected.

    This worked for me. Let me know if you have any troubles with it.
    I haven’t been able to find any other solution on the web, even though lots of people are having issues with it since the 1st of August.

    Best regards,
    Sebastian Csadi

    Thanks so much Sebastian, this worked perfectly for me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Fotobook] There are no albums text appears above header’ is closed to new replies.