Support » Plugin: Fotobook » [plugin fotobook] Can’t get albums

  • Hello,

    I’m running WP 3, I have PHP5, and fotobook 3.2.1. I have successfully linked my facebook account but when I go to manage albums and choose get albums, it says albums imported successfully, but then below says There are no albums. I checked my privacy settings on facebook, and changed it to where “everyone” can view photos. I also made sure the fotobook app was granted permission. How can I fix this?

    Thanks

    http://wordpress.org/extend/plugins/fotobook/

Viewing 15 replies - 16 through 30 (of 40 total)
  • Hey I’m using WP 3.0.1 and php 5.
    Every time i try to apply permission i get the message
    Unable to activate account: Invalid parameter
    I’ve tried giving facebook permission and it still gives me the same error.
    Please Help.
    Thanks

    All of the sudden I can’t get my albums anymore!?!? I’m getting this error: Fatal error: Uncaught exception \’FB_FacebookRestClientException\’ with message \’Incorrect signature\’ in /home1/amigohis/public_html/wp-content/plugins/fotobook/facebook-platform/facebookapi_php5_restlib.php:3003 Stack trace: #0 /home1/amigohis/public_html/wp-content/plugins/fotobook/facebook-platform/facebookapi_php5_restlib.php(1608): FB_FacebookRestClient->call_method(\’facebook.photos…\’, Array) #1 /home1/amigohis/public_html/wp-content/plugins/fotobook/fotobook.php(258): FB_FacebookRestClient->photos_getAlbums(\’100000894427956\’, NULL) #2 /home1/amigohis/public_html/wp-content/plugins/fotobook/fotobook.php(664): FacebookAPI->update_albums() #3 /home1/amigohis/public_html/wp-includes/plugin.php(395): fb_ajax_handler(\’\’) #4 /home1/amigohis/public_html/wp-admin/admin-ajax.php(1531): do_action(\’fb_ajax_handler\’, Array) #5 {main} thrown in /home1/amigohis/public_html/wp-content/plugins/fotobook/facebook-platform/facebookapi_php5_restlib.php on line 3003

    Please help… where do I donate money so this plugin can be fixed?

    johnrz

    (@johnrz)

    I have re-set my permissions for fotobook to import albums from facebook, using your link provided. I get a message telling me “success”. When I go to bring albums into word press site, nothing happens. I can still see previously imported albums and those others greyed out that I do not want to show on my word press site. However, more recently added albums do not come in for me to choose to display or not to.

    helpforyourpet

    (@helpforyourpet)

    I’m having the same problem. When I try to “Get Albums,” nothing happens. The albums I previously imported are there, but recently added pictures and albums do not come in. The link did not fix this problem, even though I got the “success” message.

    herrin

    (@herrin)

    I just got this working again by unlinking the account from facebook and starting again from the beginning.

    Hope this works for you too!

    helpforyourpet

    (@helpforyourpet)

    It didn’t work for me. It just removed all my albums, and now I can’t get any albums. I’ve tried uninstalling it completely and deleting it from facebook then re-installing everything, still nothing.

    I had it working for a while but it stopped recently and I am getting the same error. I tried unlinking as well and now I have no photos.

    I had it working for a while but it stopped recently and I am getting the same error. I tried unlinking as well and now I have no photos. Please help!

    taxbax, Have you tried disabling other plugins? I don’t know much about fotobook as I’m new to it but I know that sometimes a new plugin can mess with already working ones.

    unfortunately this is a client’s live site so I can not disable anything. However, the plugin was functioning totally fine just a few days ago so I do not believe plugin interference to be the issue. Also, the error I am getting looks surely to be from the Facebook API and all of these others in the thread have had it.

    jayjayNZ

    (@jayjaynz)

    Awesome little plugin – saved me sh!tloads of work :); I love it.

    I had the errors too, but it was because I had the fan-pages hack enabled (see: http://c.hadcoleman.com/2010/01/embed-facebook-fan-page-photo-albums-in-wordpress/) so removed it and it worked again.

    @aaron_guitar any chance of including fan pages into the fix, or maybe include the ability to add fan-pages directly from the plugin, so we don’t need to hack your wonderful work? – Thanks.

    jayjayNZ

    (@jayjaynz)

    Actually I just found a workaround for pages 🙂

    If you follow the steps on this page: http://c.hadcoleman.com/2010/01/embed-facebook-fan-page-photo-albums-in-wordpress/ but, in fotobook.php replace every instance of

    $session[‘uid’]

    with

    $uid

    There should be 3 or four on the page. Once done, don’t worry about adding any permissions as you’ve basically overwritten them with the hard-code. I think you need your albums to be public though.

    Got my page working again after this 🙂

    Thanks again for a wonderful plugin.

    I tried and it didn’t work

    Scratch that, it worked! yaya! but i had to remove the already activated/allowed accounts that must have been still in the database from the modified, Chris Wright, plugin.

    Lets hope this fix holds!
    Client will be happy

    PurrfectFire

    (@purrfectfire)

    I erased all.
    Added the plugin new
    Gave permissions
    Used the link to ad photo import in FB
    Tryed to import

    I still get

    Fatal error: Cannot redeclare wpbook_safe_publish_to_facebook() (previously declared in /home/furryta1/public_html/blog/wp-content/plugins/wpbook/publish_to_facebook.php:6) in /home/furryta1/public_html/blog/wp-content/plugins/wpbook/publish_to_facebook.php on line 179

    Where do I go wrong?

    See where your code says “wpbook_safe”? You’re clearly using WPBook so either it is conflicting with Fotobook or you are writing in the wrong thread.

Viewing 15 replies - 16 through 30 (of 40 total)
  • The topic ‘[plugin fotobook] Can’t get albums’ is closed to new replies.