Support » Plugins and Hacks » [Plugin: ForumConverter] Outdatted and confused

[Plugin: ForumConverter] Outdatted and confused

  • Hey there, glad to see this mod exits and thank you for making it. However, it seems this is a bit outdatted. Are there any plans to update it to support phpbb 3.10 and bbpress 2.1?

    Additionally, I am a bit of a noob and some of these area conused me when trying to fill out the information:

    “Source server prefix” <- what is that?
    “Source server upload path” <- Do you mean where my phpbb forum is located?
    “Source server avatar path” <- Do you mean where my phpbb form avatars are located?

    Again, great mod and thank you for taking the time to do this.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Source server prefix is basically the table prefix used by your source software. e.g. phpBB will typically use phpbb_

    Source server upload path is where the uploads (attachments, etc) are stored.

    Source server avatar path – you got it.

    BTW, I have tried to use forumconverter a few times, and it didn’t work out for me. I’ve had more luck with bbconverter http://wordpress.org/extend/plugins/bbconverter/

    I got ForumConverter to convert a phpBB 3.0.9 install to bbPress 2.2.3 by adding the bbPress version number to line 33:

    if (!in_array($dbver, array('110',   //2.0-rc-2, 2.0-beta-3, 2.0-beta-3b
                                                        '155',   //2.0-rc-3
                                                        '165',   //2.0-rc-4
                                                        '200',    //2.0 final
                                                        '223'    // ADD THIS

    and removing three sets of references to the blog_id field which was removed in WP 3.4… the result should look like this:

    $status = $wpdb->insert($wpdb->prefix.'options',
      array( //'blog_id'      => 0,   // note commented blog_id here...
                                                               'option_name'  => '_bbp_super_sticky_topics',
                                                               'option_value' => $data,
                                                               'autoload'     => 'yes'
      array( //'%d',//blog_id  // .... and comment here too
                                                               '%s' //autoload
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: ForumConverter] Outdatted and confused’ is closed to new replies.