Support » Plugin: Force Regenerate Thumbnails » [Plugin: Force Regenerate Thumbnails] All failures?

  • Resolved n2codes



    I was excited to hear about this plugin because I do not hardcode urls like most people and secondly because who wants all those thumbnails laying around if we don’t need them, right? But it’s vague use of instructions had me thinking I needed to uninstall Regenerate Thumbnails first. So did. I used this and all 29 thumbs that I had were failures. So without panic I simply reinstalled Viper007’s version and tried to regenerate and all were failures again. Eek.

    So then I decided to uninstall your plugin and regenerate again with Viper007’s version and bingo, all was back to normal, no failures.

    So..Additionally I thought well, maybe because I uninstalled viper007’s version in the first place was the wrong thing to do so reinstalled your plugin with viper007’s version and tried again. Again your plugin failed to regenerate any thumbnails. So now I’m scratching my head wondering why?

    What is the proper use for this plugin? And why did I regenerate nothing but failures with or without viper007’s version installed?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Pedro Elsner


    (Sorry for my english poor)

    Hello Man,
    It’s very strange…
    The only difference between this plugin of the version to Viper007 is that this DELETE ALL THUMBNAILS FORMAT before performing the routine.
    The Viper007’s version do regenarate thumbnails for only new thumbnails format.
    Can you send to me the message error/failure?

    Hello there,

    Like @n2codes did, I got a bunch of failures each time I try to regenerate my images.
    The failure error is:
    function (){if(!d){var c=arguments,g,h,i,j,k;b&&(k=b,b=0);for(g=0,h=c.length;g
    Thanks for helping!

    ditto with regards to the messages –
    but I can confirm that all the thumbnails were actually regenerated.
    BTW. I don’t believe that this topic is actually resolved.

    Plugin Author Pedro Elsner


    Can you send a screenshot with the error?
    Thank you.

    Sorry I can’t reproduce the bug as long as I don’t want to regenerate all the bunch of images. I tried to regenerate few images from the “Media” page, it worked like a charm.
    To help you to get a picture, below is how the error was displayed:

    1. "image1" (ID 1): All thumbnails was successfully regenerated in 7,874 seconds.
    - Thumbnail: 150x150 was deleted.
    - Thumbnail: 800x800 was deleted.
    - Thumbnail: 206x300 was deleted.
    - Thumbnail: 214x214 was deleted.
    - Thumbnail: 160x160 was deleted.
    - Thumbnail: 704x1024 was deleted.
    - Thumbnail: 290x290 was deleted.
    - Thumbnail: 550x800 was deleted.
    2. function (){if(!d){var c=arguments,g,h,i,j,k;b&&(k=b,b=0);for(g=0,h=c.length;g
    3. "image3" (ID 3): All thumbnails was successfully regenerated in 7,874 seconds.

    I have the same error here, with the javascript code “function blabla” displaying instead of the success message.

    It seams that this problem appears in conjunction with an ERROR 500 reply from the server. The javascript code that gets displayed is from the minified jquery source. In my opinion, you should seek for the bug in the followed bunch of code (l296 of the main file):

    if (success) {
    	rt_successes = rt_successes + 1;
    	$("#regenthumbs-debuglist").append("<li>" + response.success + "</li>");
    else {
    	rt_errors = rt_errors + 1;
    	rt_failedlist = rt_failedlist + ',' + id;
    	$("#regenthumbs-debuglist").append("<li>" + response.error + "</li>");

    The success/failure test perhaps fails.

    Plugin Author Pedro Elsner


    Hello guys, the version 1.2 was already avaliable.
    Please, check if was fixed.

    1.3 and still this error

    function (){if(a){var t=a.length;(function r(t){v.each(t,function(t,n){var i=v.type(n);i===”function”?(!e.unique||!c.has(n))&&a.push(n):n&&n.length&&i!==”string”&&r(n)})})(arguments),i?o=a.length:n&&(s=t,l(n))}return this}

    Though, I feel that the regeneration fails when old thumbs are not there anymore. I can’t debug that since the error doesn’t give you any info (wp_debug in on).

    All done! 0 image(s) were successfully resized in 153 seconds and there were 297 failure(s). To try regenerating the failed images again, click here. To go back to the previous page, click here.

    Retry doesn’t help either.

    I will try to switch to another plugin an will report back.

    Ok, got it working.
    I noticed that though the plugin showed a message “Thumbs was deleted” the actual file was left hanging on the server (permission 777), but I decided to reset the whole dir recursively to 777 anyway, just to make sure. After that, no failures… But still old thumbs are there…

    Got the same issue.. even after setting the upload and all subfolders to 777

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Force Regenerate Thumbnails] All failures?’ is closed to new replies.