WordPress.org

Support

Support » Plugins and Hacks » [Plugin: FLV Gallery] Help with using

[Plugin: FLV Gallery] Help with using

Viewing 15 replies - 1 through 15 (of 37 total)
  • I have to admit – the concept of this gallery looks great; but I cannot see instructions on how to embed the files.

    interested as well!

    First off, thanks for your interest – this was my first plugin so I had no idea if anyone would ever be interested.

    I have submitted version 1.1 that has a few changes that should make the plugin work better:

    – I changed the way that some of the dependencies were being referenced to better fit with the WP plugin standards
    – I updated the README with more details about how to use the plugin

    My initial use of the plugin was on a WP MU site, but I tested this new version on a fresh 2.7.1 install (not MU) and found a few issues. Those have been fixed, so this should work up to 2.7.1 now.

    Please reply if the instructions aren’t clear or if you have any issues using this.

    This is a great plugin. I’m now using it ont he Virtual Film Festival.

    I’ve had no probles except for a couple of things, but quite a major thing.

    When I bring up the screen, it doesn’t show me the close button (as it does on your demo). It’s strange, because if I go to the area where the X would be, it does actually close it, but it can be a bit hit and miss and I can’t ask my users to do that.

    Secondly, I’m not sure what to put in the Modal Player Style in admin.

    For a first plugin, this is a major player. Thanks for providing it.

    Moonworks – if you view source on your page you should see some CSS styles added to the header, including one for the X to close the window. The code is:

    <!– FLV Gallery Styles –>
    <style type=”text/css”>
    #modalContainer a.modalCloseImg {
    background:url(<?php echo WP_PLUGIN_URL; ?>/flv-gallery/x.png) no-repeat;
    width:25px;
    . . .

    The url to the file should be something like “http://mydomain.com/myblog/wp-content/plugins/flv-gallery/x.png”.

    There should be a file called “x.png” inside the plugin folder – to make sure you can get to it just copy the location from your source into the address bar of your browser and see if you can get to it.

    As for the modal player style, start with something simple like this:

    backgroundColor: ‘#ffffff’, border: ‘3px solid #75001b’

    This is what I’m using on the “demo” page, for a white box and a dark red border.

    Problem solved :o)

    There was no x.png file in the plugin folder, so I just went ahead and created one, now it shows up no problem.

    Thanks for the help.

    Great plugin.

    I have one problem though: my video is not centered inside the window. it is off to the right side.
    Is it a CSS problem?
    here is a link to my site: http://www.jimmylocust.com/News/?page_id=15

    thanks.

    Jimmy –
    I’ve updated the main PHP page with a slight change to the javascript that sets the width & height of the modal dialog. This should fix the issue you were having.

    Thanks for the feedback.

    It is working great now.
    Thank you.
    and thank you for your quick respond.

    Hi Russell,

    I, too, LOVE your plugin…simply wonderful ! I am having a small spot of trouble getting the <optional click to> to actually display. You can see a sample page in which I’m having the “non-display of URL <click to> at:
    http://endowinguniversity.com/?page_id=2
    …I used there the following code with two different approaches to try and get the <click to> to display:
    ` [flvgallery video=”http://endowinguniversity.com/images/SlowMeDown.flv” title=”Title for Video 1″ caption=”Optional Caption Video 1″ thumbnail=”http://endowinguniversity.com/images/SlowMeDown.jpg” url=”http://endowinguniversity.com/?page_id=2″ url_icon=”http://endowinguniversity.com/images/Arrow.png” width=”400″ height=”225″] [flvgallery video=”http://endowinguniversity.com/images/SpeakingofLove-1.flv” title=”Title for Video 2″ caption=”Optional Caption Video 2″ thumbnail=”http://endowinguniversity.com/images/SpeakingofLove-1.jpg” url=”http://endowinguniversity.com/?page_id=44″ url_text=”More” width=”400″ height=”225″] ‘

    I also noticed that in the file “flvgallery.php” there seems to be a typo in this URL area:
    url_text="<optional link text"> ..notice the “quote” is on the wrong side of the bracket…but that probably does not matter because fixing that has no effect on my problem.

    Also, you can see on my homepage at http://www.endowinguniversity.com that I use the Mixpod.com player for music, and that uses JQuery, and the Mixpod player covers up the Flv Gallery such that you can’t click the “X” to close it out. I was wondering if there’s a way to adjust the FLV Gallery to always display “left of center” so that the Mixpod player would never cover it ??

    Kindest Regards and Highest Respect,

    Jeffrey!
    Seattle, WA

    Pursuint to my last post above, I finally figured out that in the WordPress Dashboard I needed to click the “HTML” tab instead of the “Visual” tab to insert the code for FLV Gallery. When in “Visual” mode extra characters are inserted that disable the display of the URL <optional click to>.

    So, I’m now able to get it to work with the url_text option but I still can’t get the url_icon option to work. You can see this at http://endowinguniversity.com/?page_id=2

    Here’s the code:
    [flvgallery video="http://endowinguniversity.com/images/SlowMeDown.flv" title="Title for Video 1" caption="Optional Caption Video 1" thumbnail="http://endowinguniversity.com/images/SlowMeDown.jpg" url="http://endowinguniversity.com/?page_id=2" url_icon="http://endowinguniversity.com/images/Arrow.png" width="400" height="225"]

    And Mixpod still covers the Flv Gallery 🙂

    Kindest Regards,
    Jeffrey!

    Hello,
    I am very glad to know about this plugin. I interested in it and downloaded and followed the installation procedure. After per all the instructions, I started to play the flv file by clicking on the thumbnail on my page. But it is not playing, instead it is asking whether the file is to be saved or played. By chosing the play option, there is only a blank white screen window. I had uploaded the flv file and preview image in to the uploads folder of wordpress.

    Please help me to enjoy this wonderful plugin as it is required for me. I had visited the demo and so I am appreciating the team behind this pluggin.

    Thank You,
    Sijo P Jose
    sijocyber@gmail.com

    I am experiencing the same thing as Sijo — only with IE. My friend’s IE/PC has the exact issue described above. My IE8 /PC Vista goes through the save or play boxes and actually will play the video, but it’s not in the FLV Gallery player.

    Everything works as advertised Firefox Safari.

    Is there a fix for this? It is a terrific plug-in otherwise, would hate to have to abandon it.

    sjocyber & nazzman – I had the same issue. In my case the fix was easy. Make sure the closing single quote (‘) is at the end of the Modar style configuration line as shown below:

    backgroundColor: ‘#ffffff’, border: ‘3px solid #75001b’

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Plugin: FLV Gallery] Help with using’ is closed to new replies.
Skip to toolbar