Support » Plugin: Floating Social Media Links » [Plugin: Floating Social Media Links] Headers Not Sent Error

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Nick Halsey

    (@celloexpressions)

    Hi, my best guess would be that there was interference with another plugin. Could you tell me which other plugins are active? Then I can try to reproduce the issue and find the exact error/solution.

    Plugin Author Nick Halsey

    (@celloexpressions)

    I was able to confirm that this error shows up on completely clean installs, and think I found the source. It is completely safe to use the plugin though, as the error will only show up when in the original activation process (it’s an issue with setting defaults). The “unexpected output” is just code that’s being echoed instead of executed.

    I should have a minor bugfix update out with the fix within the next day though, if you’d rather wait for it.

    Plugin Author Nick Halsey

    (@celloexpressions)

    Actually, that wasn’t the issue, and it seems that it’s been an issue for clean installs since version 1.3.0. I have no idea what those characters are or where they’re coming from, since I’m getting a different number so it’s probably something dynamic; I’ll keep looking.

    In the meantime, the plugin is perfectly safe to use, it just does something wordpress doesn’t expect when originally activating.

    Plugin Author Nick Halsey

    (@celloexpressions)

    Update is out with the fix!

    The bug was extremely difficult to detect and locate (I actually had to modify the WP core of my installation to get more info on it). It was perfectly safe, for some reason wordpress was trying to get plugin options before they were created – resulting in a php notice; php notices are output before headers, and only if WP_DEBUG is true.

    THANK YOU for pointing this out to me, I’m shocked no one has mentioned it since it’s been an issue for a month and a half (only affecting new users with debug true…)!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Floating Social Media Links] Headers Not Sent Error’ is closed to new replies.