Support » Plugins and Hacks » Floating Social Media Links » [Resolved] [Plugin: Floating Social Media Links] Custom links Not working

[Resolved] [Plugin: Floating Social Media Links] Custom links Not working

Viewing 15 replies - 1 through 15 (of 16 total)
  • Incidentally, in case it helps, ALL of the options are showing up on the same settings page (instead of being broken up into the tabs across the top).

    Plugin Author Nick Halsey


    Hi, that does help, it sounds like the scripts aren’t running on the admin page. The ability to switch between options tabs, add custom links, as well as some options that are switched on and off based on other options, all rely on this script, which requires jQuery which wordpress should be enqueuing. My best guess would be that some other plugin or your theme swaps out the default jquery for a custom one or another possibility is that you’re using an old browser or have javascript disabled.

    I did just remember that I’m still not using wordpress’ “safe” method for including script; I’ll make sure I make the change in the next update and at that point any issues with the needed scripts being missing should be gone.

    In the meantime, you should be able to get to the new custom link section in Chrome if you inspect element on the add custom link button, select the next <tr id=…> underneath the commented “custom url #1 (Blog, etc.)”, and uncheck the display: none; css you should be able to set up the options and they shouldn’t be hidden when you save the options as long as you select the “show link”.

    Thank you so much for the work around. That worked great. I got to add my Steepster link to the site at 52teas.com. Much appreciated!

    Plugin Author Nick Halsey


    Great! And hopefully after the next update all of this functionality will work as it should in the admin interface.

    Just an FYI: The latest update did NOT resolve this issue for me. I used your work-around solution to add a link to our Tumblr page. Still love the plugin.

    Plugin Author Nick Halsey


    Shoot! My best guess then would be that there’s a compatibility issue of some sort with another plugin. Obviously I need to make sure that everything works as intended regardless of configuration… so would you mind finding the JavaScript errors (which should hint at why it isn’t working)?

    If you open it up in chrome again (other browsers will work, but chrome tends to isolate bigger issues better), right click anywhere and choose inspect element, then click on the red x icon with a number next to it in the bottom right corner. Then copy and paste all of the errors/warnings that come up. Then maybe I can see what might be happening…

    Hi Nick. Great plugin!

    Unfortunately, my websites don’t seem to link properly (and the topmost link in particular). The links on the lower icons do seem to work though. Anyway, I’ve installed your plugin on three of my sites (just to give it a go!) and hopefully they work in the future. If you have any ideas to fix this problem, it would be greatly appreciated!

    Plugin Author Nick Halsey


    Hi, could you provide a link to your website so I can see exactly what’s going on? Is it the first custom link or a build-in (facebook, youtube, twitter) link? My guess would be that I have a bug in the link validation, which adds http://s.

    I forgot you had asked for this information:

    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/yak-module-gallery/lightbox.js?ver=2.04
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/yak-module-gallery/lightbox.css
    Uncaught TypeError: Object [object Object] has no method ‘dispatchEvent’ load-scripts.php:4619
    Uncaught TypeError: Object [object Object] has no method ‘farbtastic’ fsml-admin.js.php:2
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/floating-social-media-links/imgfacebook.jpg
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/floating-social-media-links/imgtwitter.jpg
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/floating-social-media-links/imgyoutube.jpg
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/floating-social-media-links/img/more-default2.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/floating-social-media-links/img/more-default4.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/floating-social-media-links/img/more-default3.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/floating-social-media-links/img/more-default5.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.52teas.com/wp-content/plugins/floating-social-media-links/img/more-default7.png

    Hi Nick,

    It’s the first custom link for each one.



    Plugin Author Nick Halsey


    Zoomdweebie: I think the yak module gallery plugin (which is probably essential to your site) has a bug that is preventing all of its scripts, as well as those being run by other plugins from loading. Try deactivating then reactivating that plugin, as well as making sure it’s the latest version. Sometimes a manual reactivation in necessary when updating certain plugins (not the case for mine).

    If that doesn’t work, then the author of that plugin needs to fix the issue, it is relatively technical so I can do that through that plugin support forum if you’d like. You can also implement a manual solution temporarily if you’ll need to wait for the other plugin to be updated.

    If anyone wants the more technical version, it appears that the 404 for the lightbox.js file is preventing wp-load-scripts from loading all of the scripts, namely in this case farbastic (the color picker). Then when the fsml admin script is run it can’t get past the part that sets up farbtastic, which happens to be first. All of the other errors are missing default placeholder images that have been removed in favor of a single image in version 3.1.1.

    By the way, you should be able to clear out several of those messages by hitting “save options” for my plugin, which will update some unused/hidden options that changed with a recent update.

    Let me know if de/reactivating that other plugin doesn’t work, in which case I’ll give you the temporary fix and ask the other plugin’s author to address the bug.

    el_ganadores: I’m looking at your issue now.

    Plugin Author Nick Halsey


    Ok, el_ganadores, it looks like the first link setting is completely blank/empty, which shouldn’t be possible with fsml version 1.3.0 and higher. Which plugin version are you running? If there’s an update try doing it and see if you still get the same result.

    Could you also paste in what the first link url field says, then if it changes after you save the settings (you can just do this for one of the sites)? I’m unable to replicate the issue with the dev version of the plugin and various link combinations similar to yours.

    I did notice a bug that (although not the cause of your issue) is directly related; however it is irrelevant if the links can’t be blank (the case with the newer versions), so I won’t be fixing it…

    Thanks for the very thorough response. I’ve got your plugin doing what I want it to do now, so I’m really okay with it, but I did forward your response on to the Jason (YAK developer) as a courtesy to him (and since you took such pains to line out the problem). That’s my shopping cart, and yeah, it’s pretty crucial.

    I’ve downloaded the latest version (1.3.3) for all websites.

    It seems to work now. What I’ve done, is have three icons with links to external sites (custom links). However, I’ve clicked off “show link” for the first custom link. Hooe that makes sense.

    For example, I have ‘fixed’ the http://www.studentview.com.au website by having three custom links with icons (studentcoupon.com.au -hidden- then studenttrade.com.au then studentcoupon.com.au).

    Ideally, I could just have each of them show up without the extra one hidden. Not sure what’s causing the problem though 🙂

    Plugin Author Nick Halsey


    Zoomdweebie: thanks, hopefully he can resolve the issue with his plugin which should in turn make this and others work better in the future.

    el_ganadores: that’s a good workaround, although I’m still not sure why it isn’t working. I did notice that you were getting two urls with a space between them for the first link now on the site you just linked… hopefully that’s just wrong in the options, or there may still be an issue…

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] [Plugin: Floating Social Media Links] Custom links Not working’ is closed to new replies.
Skip to toolbar