Support » Plugin: flickrRSS » [Plugin: flickrRSS] Fatal error when upgrading to version 5.2

  • I was using flickrRSS Version 3.2 with no problems. I upgraded to 5.2, and it broke. I get this error message: “Fatal error: Call to undefined function get_and_delete_option() in … /wp-content/plugins/flickr-rss/flickrrss.php on line 27.” Anyone know how to fix this? Or what’s causing it?

    http://wordpress.org/extend/plugins/flickr-rss/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Dave Kellam

    (@eightface)

    It was a check to see if you had an older version of flickrrss installed, and to update the options in the database. In all honesty, I forget if there were other database tweaks between 3.2 and 5.1, it’s been years. Did you get it fixed at all, or just revert to an older version?

    I hired a programmer to fix it. This is what he told me: “It looks like the plugin author did not reference the object where the function exists properly, as such it broke the call to the function and with it the plugin. It’s now corrected and the plugin is active for you. I do not suggest re-installing this plugin as it will revert my changes. Specifically the setupActivation plugin now reads:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    Plugin Author Dave Kellam

    (@eightface)

    Any chance you could drop the code on pastebin? The forum rules don’t let anyone post code.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: flickrRSS] Fatal error when upgrading to version 5.2’ is closed to new replies.