Support » Plugins » [Plugin: Flickr Gallery] Unable to Generate Auth Token

  • Resolved chasingtwilight

    (@chasingtwilight)


    WHAT A GREAT PLUGIN!

    I am able to do this and get everything working just fine for my public photos. However, when I put in all the correct information so that my private photos can be shared, I get stuck at the Auth Token. It “generates”, I give it permission on flickr, so then it is “done authenticating at flickr”- but I never get a token to put in that last box. I’m not sure if it’s an error on my end (I’ve tried doing this in Chrome, FF, IE, and Opera and it still won’t generate). I looked at the documentation for creating my own auth token attached to the same API on flickr but I also seem to be getting stuck there.

    Help?

    (And as a random side note, is there anyway to install this plugin twice so I can do this from two different flickr accounts? Or is there any point in the future where you might add the ability to add more than one account to the plugin at a time?)

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Try generating a token with this tool:
    http://phpflickr.com/tools/auth/

    Oops! Flickr can’t find a valid callback URL.

    An external application has requested your login credentials and permission to perform certain actions on your behalf, but has failed to include all the required data.

    You don’t really need to know what this means, except that you can’t use the application until this problem is fixed. (It’s a third-party problem, not a Flickr problem.)

    There are lots of applications using the Flickr API. If you are curious about this, visit the Flickr Services page to see more examples of cool stuff. Otherwise, you might like to head to your home page…

    I’ll try messing around with this too and get back to you.

    I’m still unable to generate an auth token, and I keep getting the third-party error.

    I’d love to be able to use this plugin, but most of my photos on flickr are friends/family only. Is there anyway we can take advantage of the guest pass feature so that I’m able to display these? Is anyone else having problems when they try to use this plugin for private photos?

    OKAY.

    For those of you that are having this problem, I solved my problem, so I figured I’d share the how-to with you. I’m no coder, so there’s probably an easier way to do this- but here it is.

    • Fill in ALL info requested (except token) on Dan’s Flickr Gallery plugin settings page on your blog.
    • Click “generate” and it should take you to flickr
    • Give permission, of course.
    • Back at the Flickr Gallery plugin, there probably isn’t a token generated in the appropriate slot- but the status had changed from “generate” to “done authenticating at flickr”.
    • Right click on the “done authenticating at flickr” and copy the link.
    • COPY the numbers after the frob= until the &. (The “MORENUMBERS”)
    • Paste the numbers you just copied (the “MORENUMBERS”) into the value box.
    • Check sign call with full permissions.
      Underneath, your token should pop up.
      Your text should look similar to this:

      <auth>
      <b><token>976598454353455-88822111-4555322</token></b>
      <perms>write</perms>
      <user nsid=”12037949754@N01″ username=”Bees” fullname=”Cal H” />
      </auth>

    • Copy the token number and then return to your wordpress blog and put it in your Flickr Gallery settings.

    Just want to take a moment to thank you for the advice on how to get this to work!

    I couldn’t figure it out. Thanks!

    I want to second AzJade – thank you!

    Thanks! This page helped me as well.

    Scratch that, I figured out my issues.

    I’ve tried this work around and I don’t have any numbers between frob= and &.

    Any ideas?

    When I click on generate token, I get the Flickr message that the API key is not authenticated.

    I’m using Flickr Gallery 1.3, but not WP 2.9 yet.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Flickr Gallery] Unable to Generate Auth Token’ is closed to new replies.