Support » Plugin: Flattr » [Plugin: Flattr] Prevents caching of main pages due to Set-Cookie header

  • Resolved moepstar

    (@moepstar)


    Hi,

    as it is now, enabling the Flattr plugin prevents the site getting cached as it sets a cookie on each page load.

    Caching is implemented via NGINX <-> Apache reverse proxy setup and as NGINX doesn’t cache hits with Set-Cookie (and rightly so) it effectively prevents the main URL of a post/page/main website from getting cached..

    Is there a way around this behaviour?

    http://wordpress.org/extend/plugins/flattr/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author VoxPelli

    (@voxpelli)

    I can’t see that how the Flattr plugin would be setting any cookies in a WordPress blog? There is no mentioning of “cookie” in its entire code base and I also can’t see any reason for why there it would set any.

    Can you elaborate on why you believe that it’s the Flattr plugin that is setting this cookie?

    moepstar

    (@moepstar)

    Can you elaborate on why you believe that it’s the Flattr plugin that is setting this cookie?

    Uhm, let me think about it – maybe because it does? 😉

    Just curl -i http://website.com and see which cookies get set with the plugin enabled and with it being disabled…

    Plugin Author VoxPelli

    (@voxpelli)

    If you’re sure the Flattr plugin has something to do with it then I believe you and we of course should track the cause of that down!

    Sorry if this might be a stupid question, but which cookie is it that you see set when the Flattr plugin is active? What’s the name of it?

    Plugin Author VoxPelli

    (@voxpelli)

    Found the reason for this – for some reason the plugin always initialized a session as the first thing it did. I can’t see any reason why it would do that and the commit where it was introduced didn’t give any reason for it either so it will be removed in next version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Flattr] Prevents caching of main pages due to Set-Cookie header’ is closed to new replies.