WordPress.org

Forums

Flattr
[resolved] Individual profiles on multi authir site not working (3 posts)

  1. mabahl
    Member
    Posted 3 years ago #

    I've been struggling to make Flattr work on my website for a while now, because I really want to see the system flourish. It has great potential, but right now I'm very close to giving up.

    I run a multi author website and love the idea that Flattr-buttons are connected to the author of the article. However, it only seems to be working on a few articles in my case. The large majority of the articles on my site is simply connected to the general Flattr account for the site.

    I have tried a lot of different things to try to make this plugin work, and it feels like the problem is that a lot of the articles are already connected to the general Flattr profile, which now cannot be overwritten.

    I haven't presubmitted all articles, but should that be a problem even if I did?

    I have tried to delete the plugin and all flattred articles, but when I reinstall the plugin all settings are saved. Even after clearing cookies, caches and using a different browser.

    At this point I feel the only solution would be to simply start over. Completely. But how do I do that? How do I delete EVERYTHING and clear the slate completely?

    I hope you can help me. I would love to see this plugin work!

    http://wordpress.org/extend/plugins/flattr/

  2. VoxPelli
    Member
    Plugin Author

    Posted 2 years ago #

    I believe that I have found the cause of this - the plugin tries to get around a few errors that might occur when switching owners on already flattred things but it does this in a way that stops all old posts on a site from being assigned to anything but the site wide Flattr account.

    I will make this work better in the next version that will be out very soon.

  3. VoxPelli
    Member
    Plugin Author

    Posted 2 years ago #

    Version 1.2.0 is out now and it now exposes a previously hidden setting that has a timestamp that posts has to be newer than to have the user specific buttons apply to them. Now one can change it in the settings through the "Limit to posts after" field and either leave it empty to disable the limit altogether or just change it to another date. This should fix this issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags