Support » Plugin: Flattr » [Plugin: Flattr] Capabilities check freezes up

  • Trying the authorization wizard with version 0.99.1

    Running server capabilities check
    checking cURL curl_init
    checking oAuth OAuth2Client
    checking php 5.2.17
    checking WordPress 3.3.1
    checking Flattr ...

    There it stops. I can only click “Cancel”. The same happens with 2 installations on different servers (shared webhosting).
    Does it mean that the Flattr website is down?
    Thanks!

    http://wordpress.org/extend/plugins/flattr/

Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author Michael Henke

    (@aphex3k)

    Try opening http://localhost/wp-admin/admin.php?q=Flattr&flattrJAX=true&page=flattr%2Fflattr.php where you replace localhost with your blogs domain name of course, what is the result?
    If it works, it should return something like this:

    {“result”:”passed”,”feature”:”Flattr”,”text”:”connection established”}

    It returns on both servers:

    Warning: curl_error(): 214 is not a valid cURL handle resource in /blablabla/wp-content/plugins/flattr/flattr.php on line 148
    {"result":"failed","feature":"Flattr","text":false}

    The number 214 sometimes changes.

    Plugin Author Michael Henke

    (@aphex3k)

    If you can, please replace lines 136 to 150 (from case “Flattr” to break; in flattr.php with the following lines:

    case “Flattr” :
    $retval[“text”] = “Flattr API v2”;

    $ch = curl_init (‘https://api.flattr.com/rest/v2/users/der_michael’);
    curl_setopt ($ch, CURLOPT_RETURNTRANSFER, 1) ;
    $res = curl_exec ($ch) ;
    $res = json_decode($res);
    if (isset($res->type)) {
    $retval[“text”] = “connection established”;
    $retval[“result”] = PASS;
    } else {
    $retval[“text”] = “curl connection error “.curl_error($ch);
    }
    curl_close ($ch) ;
    break;

    and then check again please.

    Did one more experiment: I moved the
    curl_close ($ch) ;
    from line 142 to line 150. Trying the wizard now gives me a changed result:

    checking cURL curl_init
    checking oAuth OAuth2Client
    checking php 5.2.17
    checking WordPress 3.3.1
    checking Flattr SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    Sorry, got your post above only now. Did I do what you wanted me to do? Or still need to try?

    Plugin Author Michael Henke

    (@aphex3k)

    ok, thanks, please include the follwing line before the curl_exec

    curl_setopt ($ch, CURLOPT_CERTINFO, false) ;
    curl_setopt ($ch, CURLOPT_SSL_VERIFYPEER, false) ;

    Plugin Author Michael Henke

    (@aphex3k)

    curl 7.10 apparently has other default values than versions before

    The Wizard freezes again. I try the direct link, it tells me:

    Warning: curl_setopt() [function.curl-setopt]: Invalid curl configuration option in /mnt/web5/51/50/5346950/htdocs/divneveci/wp-content/plugins/flattr/flattr.php on line 142
    {“result”:”passed”,”feature”:”Flattr”,”text”:”connection established”}

    So I remove the line with “CURLOPT_CERTINFO”, now the wizard works (tried on both blogs), Flattr shows: “connection established”.

    The buttons don’t change after all tests are done – is the wizard completed?

    Plugin Author Michael Henke

    (@aphex3k)

    If all results return green, the wizard can continue, if you have a yellow or red result, the wizard will not continue. Your PHP check is yellow, right? If this is the only yellow line, modify line 114 in flattr.php to

    $retval[“result”] = PASS;

    Yes, the PHP version is yellow. I cannot upgrade PHP, my provider has the exclusive power in these things.
    What is the minimum PHP version?

    Plugin Author Michael Henke

    (@aphex3k)

    If this is the only yellow line, modify line 114 in flattr.php to

    $retval[“result”] = PASS;

    Now it continues, but after registering the application and entering key and secret, it keeps on validating.

    Plugin Author Michael Henke

    (@aphex3k)

    might be the same issue with curl close, let me look into it

    Plugin Author Michael Henke

    (@aphex3k)

    Please open the following url, what is the result? replace the <values> according to your setup:

    http://<hostname>/wp-admin/admin.php?flattrJAX=true&page=flattr%2Fflattr.php&flattrss_api_key=<key>&flattrss_api_secret=<secret>

    Warning: require_once(__DIR__/lib/httpconnection.php) [function.require-once]: failed to open stream: No such file or directory in /blablabla/wp-content/plugins/flattr/flattr_client.php on line 2

    Fatal error: require_once() [function.require]: Failed opening required ‘__DIR__/lib/httpconnection.php’ (include_path=’.:/opt/RZphp52/includes’) in /blablabla/wp-content/plugins/flattr/flattr_client.php on line 2

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Plugin: Flattr] Capabilities check freezes up’ is closed to new replies.