Support » Plugins » [Plugin: Flash Video Player] Update 4.0.6 -> Update flash player?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Getting the same error. wp ver 2.9.2

    I overwrote flash-video-player.php and swfobject.js in plugins/flash-video-player and it’s working again.

    …or perhaps I should have checked the FAQ:
    http://www.mac-dev.net/blog/frequently-asked-questions/#faq002

    I upgraded and now the player doesn’t work! or My video won’t play!

    1. With the new version of Jeroen’s player, there are some security issues with regard to referencing remote files. Any file (even those that reside on your own webserver) should be able to reference a crossdomain.xml file in the site’s root directory. This is often seen with poster images and playlists. Here’s how to fix it:

    To automatically give a movie loaded from yoursite.com access to data on http://www.yoursite.com, you must use a cross-domain policy file. The following steps describe how the owner of yoursite.com would add a cross-domain policy file to her site, thus allowing data to flow from yoursite.com to http://www.yoursite.com, and vice versa.

    Create a new text file named crossdomain.xml.
    Open crossdomain.xml in a text editor.
    Add the following XML code to the file:

    <?xml version=”1.0″?>
    <!DOCTYPE cross-domain-policy
    SYSTEM “http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd”>
    <cross-domain-policy>
    <allow-access-from domain=”www.yoursite.com” />
    <allow-access-from domain=”yoursite.com” />
    </cross-domain-policy>

    Save the file.
    Upload the file to the root directory of yoursite.com (so that the file can be accessed at http://www.yoursite.com/crossdomain.xml).

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Flash Video Player] Update 4.0.6 -> Update flash player?’ is closed to new replies.