WordPress.org

Support

Support » Plugins and Hacks » FG Joomla to WordPress » [Resolved] [Plugin: FG Joomla to WordPress] SQLSTATE[28000] [1045] Access denied for user

[Resolved] [Plugin: FG Joomla to WordPress] SQLSTATE[28000] [1045] Access denied for user

  • Hello there,
    I am having a problem to connect to the joomla database. The following error message appears:

    Erreur !: SQLSTATE[28000] [1045] Access denied for user ‘chillout_pdm_2’@’localhost’ (using password: YES)

    I doublechecked database name, username and passwort. I also installed wordpress with using the same MySQL Database as Joomla does, but still this error occurs.

    What else could I do?

    Thanks for any help!

    http://wordpress.org/extend/plugins/fg-joomla-to-wordpress/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Kerfred

    @kerfred

    Did you read the FAQ: http://wordpress.org/extend/plugins/fg-joomla-to-wordpress/faq/ ?

    Are you sure the Joomla database is accessible through localhost ? Many providers have the database on a separate host. In this case, you need to specify the MySQL host, not localhost.

    Hi,
    I have the same problem.
    I have everything running on a local machine.
    I can access the joomla database via mysql client.
    However I receive ‘Erreur !: SQLSTATE[28000] [1045] Access denied for user ‘root’@’localhost’ (using password: YES)’
    Password is definitely correct.
    Other settings:
    Joomla web site parameters
    URL : http://localhost/joomla
    Joomla database parameters
    Hostname : localhost
    Port : 3306
    Database : joomla
    Username : root
    Password : mypassword
    Joomla Table Prefix : jos_

    Regards

    Sas

    Same problem here.

    Erreur !: SQLSTATE[28000] [1045] Access denied for user ‘gltnjguv_jo152’@’localhost’ (using password: YES)

    I have tied every possible passwords.

    Plugin Author Kerfred

    @kerfred

    On Ubuntu forum, I have read that this command solves the problem :
    dpkg-reconfigure mysql-server-5.0
    If you are using Ubuntu, does this work for you ?

    http://forum.ubuntu-fr.org/viewtopic.php?id=50309

    Plugin Author Kerfred

    @kerfred

    Or on another forum:
    If you are running MySQL 4.1.x. As of MySQL 4.1.X there is a new password hashing system. PHP4 does not have builtin support for it as of yet, however PHP5 does. In order for your old PHP4 MySQL clients to be able to connect to the MySQL 4.1.X database you need to set an OLD_PASSWORD. You should be able to run the following Query to make it possible for PHP4 to access the MySQL 4.1.X database.

    SET PASSWORD FOR 'username'@'localhost' = OLD_PASSWORD('password');

    https://www.vbulletin.com/forum/showthread.php/145384-MySQL-error-Access-denied-for-user

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] [Plugin: FG Joomla to WordPress] SQLSTATE[28000] [1045] Access denied for user’ is closed to new replies.
Skip to toolbar