WordPress.org

Support

Support » Plugins and Hacks » Featured Posts Grid » [Plugin: Featured Posts Grid] w3c validator : errors

[Plugin: Featured Posts Grid] w3c validator : errors

  • Hi,

    my wordpress site has 0 errors with the w3c validator http://validator.w3.org/

    but when i activate fpg, it makes 2 errors by “cell” :

    required attribute "alt" not specified
    
    …ent/uploads/2012/09/senst-90x90.jpg" /><div class="fpg-text"><h3 class="fpg-ti…
    
    The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.
    
    Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>.

    AND

    document type does not allow element "div" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag
    
    …nst-90x90.jpg" /><div class="fpg-text"><h3 class="fpg-title">test thumbnail</h…
    
    The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.
    
    One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "<a>", "<span>", or "<font>").

    Do you have the same errors?
    Or maybe i’ve made a mistake. I only copy the code in header.php :

    <?php if (function_exists('fpg_show')) {
                $args = array(
                    'cat'     => '',/* comma separated list of category ids to include (put '-' in front of ids to exclude) */
                    'tag'     => '' /* comma separated list tag slugs to include */);
                echo fpg_show($args);
            }?>

    http://wordpress.org/extend/plugins/featured-posts-grid/

Viewing 1 replies (of 1 total)
  • Plugin Author Chaser324

    @chaser324

    These are fairly trivial errors, but they are something that I’ll make note of and correct if/when I do a future update…however, I think at this point I would probably just start from scratch and make a new FPG2 plugin.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Featured Posts Grid] w3c validator : errors’ is closed to new replies.
Skip to toolbar