Support » Plugin: Featured Link Image » [Plugin: Featured Link Image] Can not insert image adress into the input field

  • Resolved Schnitzelweck



    first: Thanks for sharing this Plugin with us. You are almost alone with a plugin that adds the media library functionality to blogrolls.

    My Problem is:
    I installed your Plugin and pressed the button “Set link image” to get the media library pop-up. Everything works fine. I uploaded my image, but what button should i click to insert the image-adress into the input field? I tried the “insert in article” button, with no effect.

    Would be nice if you can tell me what todo or fix the problem (maybe it doesnt work with the new WP-version 3.4.1 i use).

    greetings from germany

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author brasofilo


    Hi Schnitzelweck,
    thanks for reporting and sorry for the delay…

    The button that appears is the “Select link image”. Snapshot:
    Isn’t this the one that appears to you?

    After clicking it, the image is shown in the meta box, and its link is filled in “Advanced -> Image Address” field. Snapshot:

    Right now, the bug is that the image address is being filled with an enclosing anchor and image html tags, when it should be only the image URL…

    If that’s not your case, please provide me more details, thanks again!

    Plugin Author brasofilo


    Curiously enough, I couldn’t reproduce the bug I described above…

    Just revised the plugin code and released version 1.2.
    – Removed one function incompatible with PHP < 5.3.
    – Enabled the Link URL field (just in case the ghost bug comes back 🙂
    – Fully tested with WP 3.4.1

    greetings from Spain!

    Unfortunately I get the same issue: upon uploading the file from my computer, I don’t have the “select link image” button. Hence the link is not completed…

    I am on WP 3.4.2, version 1.2 of your plugin. Tested on Safari & Firefox (Mac).

    Please help me out on this, this plugin is really what I wanted to show the logo’s of my customers…

    Plugin Author brasofilo


    @tsjemo, maybe there’s a conflict with another plugin…

    Does Chrome console displays any error?

    Are you able to disable the other plugins and check?
    And swap the theme to TwentyEleven and check?

    Otherwise, I’ll need the list of plugins you’re using and theme (if not a premium one) to try to locate where this error is coming from.
    I suspect some plugin/theme may be printing its scripts all over the admin area…

    I have the same problem and i tried to pin it down.
    It seems that this:
    imgurl = $('img', html).attr('src');
    in uploader.js script is empty.
    If i manually input there a value like:
    imgurl = '';
    then everything works fine.

    Any ideas what might be the cause?

    Plugin Author brasofilo


    Mallinaga, the same answer I posted to tsjemo above applies…

    Can you answer those questions?

    Otherwise, I don’t have much elements to try to find the culprit as I’ve never been able to reproduce this problem…

    Hi Brasofilo,

    I too encounter this issue.
    My setup:
    -. WordPress 3.5 (self-hosted)
    -. accessing using Chrome 23.0.1271.97 & Firefox 17.0.1 on Win7.
    -. Theme: Twenty Twelve from WordPress
    -. Plugins: Akismet, Facebook (Facebook), Faster Image Insert (David Frank), Featured Link Image (yours), Install via URL (Michal Zagalski), ReadMore (my own, to load posts without changing into another page), Under Construction (Jeremy Massel), WP Tweet Button (Tanin Ehrami)

    Both before and after disabling the plugins (except yours), Chrome Console produced the following:

    GET http://DOMAIN/wp-admin/undefined 404 (Not Found) load-scripts.php:2
    (anonymous function) load-scripts.php:2
    v.extend.access load-scripts.php:2
    v.fn.extend.html load-scripts.php:2
    window.send_to_editor uploader.js:8
    (anonymous function) /wp-admin/media-upload.php?type=image&tab=library&post_id=0:4

    Please advise?

    Plugin Author brasofilo


    can you test this version (zip)?


    Version 1.5RC1 downloaded, uploaded, tested, and working! Thank you!

    Would you please be so kind to explain what went not-according-to-plan?

    Plugin Author brasofilo



    Two main modifications, not sure which one could be causing this random error, much probably the first.

    One in Javascript:
    tb_show('', 'media-upload.php?post_id=0&amp....

    post_id was not set before, and as the uploader is not running in any post the ID has to be zero. But, as I said, in my machine and my server, I had no problems…

    And the other in PHP:
    As there are hidden fields (description, alt, link url), case the link url was empty (could happen, but not necessarily), a PHP error would occur.

    I see. Well, I’m glad you got this sorted out (and thus mine :))

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Featured Link Image] Can not insert image adress into the input field’ is closed to new replies.