WordPress.org

Support

Support » Plugins and Hacks » FA Lite - WP responsive slider plugin » [Resolved] [Plugin: Featured Articles Lite] Issues with the image manager

[Resolved] [Plugin: Featured Articles Lite] Issues with the image manager

  • Great plugin !!!

    When dealing with the image manager (Meta box) – it only gives images from certain size – not all images (taking it probably from the height_width on the “post attached image”.

    It will probably be much better to use wordpress regular image manager to choose the slider image.

    I tried to hack add_meta.php to give me all images sizes, still no luck … ( I need it to give me also the “full-size images” )

    Any idea ?

    http://wordpress.org/extend/plugins/featured-articles-lite/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Constantin Boiangiu

    @constantinboiangiu

    In add_meta.php you see thumbnails of all images you have in wordpress. Once you select an image, depending on what size you set in slider settings for thumbnail, the slider will display the most appropriate size. May I ask why you need the full size image?

    Plugin Author Constantin Boiangiu

    @constantinboiangiu

    Sorry, I read your comment again and now I see what you mean. It’s kinda late here and I’m pretty tired. Anyway, in add_meta.php on line 151 you will find this:

    $max_size = array( $options['th_width'], $options['th_height'] );

    Change this line to:

    $max_size = array( 150, 150 );

    Let me know. I must admit, this file needs a complete rewrite. I’ll try and do this one of these days. Thank you for pointing this out to me.

    I made the above changes – think it would help with my problem below.
    But it did not.

    The problem is:
    I have Featrued Articles Lite v2.2 installed with the Smoke Theme, Thumbnail Max Size and Slider Size both set to 725px X 300 px.
    My featured images are either cut off at the bottom – or cut off to the right (entire image appears shrunk down – and there is a black bar to the right). Why would this happen when my original image is 2560 x 1920px?)

    I NEED THE IMAGE TO FILL UP THE ENTIRE SLIDER.

    BTW: When I installed pics using FA V2.1 – those images filled up the slider. Saw this problem with images after upgrade to v2.2.

    Thanks.

    Hello constantin
    Thank you for your help, but since I upgraded (2.3.7) all is changed back.

    Since some themes use big images, there got to be an option for defining the dimensions or simply use the default media manager.

    Changing line 129 from:
    $medium_size = wp_get_attachment_image_src( $post->ID );
    to
    $large_size = wp_get_attachment_image_src( $post->ID );
    didn’t help ….. so ….

    Plugin Author Constantin Boiangiu

    @constantinboiangiu

    OK, let me ask this again: when you try to add a custom image for the slider to a certain post, the problem is that you don’t see all the images you uploaded. Is this correct?

    I see the images, but just the “medium-sized” ones.
    so the picture I attache is not filling my slider.

    and my slider uses the “large-sized” …. I see some other users has the problem too , so I thought there got to be a solution for that (not just a tmp code fix … since users mught have a few sliders in one site – with verious dimentions ….

    I’ll sattle for a code fix though 🙂

    Plugin Author Constantin Boiangiu

    @constantinboiangiu

    OK, let me see if I get this. When you try to add a custom image for the slider, inside the pop-up you don’t see all your images you uploaded in media but only medium ones. Is this correct?

    Yes this is correct

    Plugin Author Constantin Boiangiu

    @constantinboiangiu

    I really don’t get it. Do you upload images using plugins developed for this purpose or you use wp media exclusively? Made some tests but I can’t generate the error you’re talking about.

    Hi Constantin,

    I just downloaded and installed your plugin, great work 🙂 I have a problem though. When I try to add a custom image for the slider (from within the post, I want to use the Smoke Theme) I can see all images displayed, but I am not able to select any. Is there a trick to do that?
    I am using WP 3.2.1 and the Roots Theme, though I do not think the theme should have anything to do with it. I uploaded a couple of example images through the Media library. Any idea?
    Thanks a lot,
    Steffen

    I have the same problem like sruefer.

    Plugin Author Constantin Boiangiu

    @constantinboiangiu

    There must be a jsvascript error causing this. Please use Firebug and put the error you see here for further investigations.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] [Plugin: Featured Articles Lite] Issues with the image manager’ is closed to new replies.
Skip to toolbar