Support » Plugin: Mailgun for WordPress » Plugin Fatal Error

  • Resolved robscott

    (@robscott)


    Hi,

    Have the Mailgun plugin installed on a site, and upgrade causes a fatal error:

    Parse error: syntax error, unexpected '[' in /var/www/vhosts/[CLIENTSITE]/httpdocs/wp-content/plugins/mailgun/mailgun.php on line 139

    Just going to troubleshoot this in that site and report back any findings.

    Note that line 139 of the relevant file is this:

    public function api_call($uri, $params = [], $method = 'POST')

    Everything worked fine before upgrade, but note this broke site on v 1.5.1, 1.5.2 and 1.5.3.

    Will comment back if / when I find solution!

    • This topic was modified 2 years, 11 months ago by robscott.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Okay I can see what this error is – PHP version on this site needed to be updated > 5.6. That works.

    Hi @robscott,

    I was running into that same problem, except I was getting a blank page in WP dashboard when I would try to activate the newly updated Mailgun plugin. I upgraded PHP from 5.3 to 5.6 and it fixed the issue!

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin Fatal Error’ is closed to new replies.