Support » Plugin: Fast Secure Contact Form » [Plugin: Fast Secure Contact Form] Session cookie error broke cron jobs in cPanel.

  • I am running cron jobs for MailPress in cPanel using php -f, instead of using wp_cron. They were working fine until I installed Fast Secure Contact Form. Now I am getting the following error and the cron jobs have stopped working:

    <b>Warning</b>: session_start() [function.session-start]: Cannot send session cookie – headers already sent in <b>/home/account/public_html/wp-content/plugins/si-contact-form/si-contact-form.php</b> on line <b>2189</b>

    <b>Warning</b>: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent in <b>/home/account/public_html/wp-content/plugins/si-contact-form/si-contact-form.php</b> on line <b>2189</b>
    1

    I have Captcha enabled, but it is set to not use PHP sessions. I tried disabling Captcha and got the same error.

    http://wordpress.org/extend/plugins/si-contact-form/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Of course I went through all of that, as I have read every post on this matter before posting myself. Since that is the only response you are giving to similar questions, those pages are hard to avoid. It is not a problem with the server. I have programmed other sites on my server that use sessions, without issue. This issue ONLY affects external cron jobs in WordPress.

    I have been programming for 14 years and it seems to me that the plugin should have some code in it that determines when and how to utilize sessions, so that it doesn’t conflict with operations that can’t use them. Either that, or allow for other Captcha options, or disable sessions and cookies when Captcha is turned off.

    I am still using FSCF, but I had to stop using external cron jobs, but I plan to program my own contact plugin, as soon as I have the time.

    ELsMystERy, I can help you.

    The CAPTCHA and vCita are the two things the session uses. It used to disable sessions when you check the CAPTCHA setting
    “Use CAPTCHA without PHP session”. But now vCita is starting sessions.
    I will make a way to turn off the session when “Use CAPTCHA without PHP session” is checked and vCita is disabled.

    I have to code and test some changes

    Ah! Thank you, thank you! vCita never even crossed my mind. I am not using that at all. I believe that may solve all of the session issues. Take your time, no hurry. Everything currently works fine without using external cron jobs.

    In the meantime you can
    check the CAPTCHA setting “Use CAPTCHA without PHP session”, and disable vCita.

    Then edit si-contact-form.php and put 2 slashes in front of this line like this:
    //add_action(‘init’, array(&$si_contact_form,’si_contact_start_session’),2);

    I commented it out and it still emails fine, but I won’t have a chance to test it with cron jobs until later. I will let you know when I do.

    I have not had a chance to test with with cron jobs yet. I have been too busy. If I can’t do it this evening, I should have some time tomorrow.

    I tried to test it with cron jobs, but after an hour with tech support it was determined that cron is now broken, so I have to wait until that gets resolved. Sorry.

    hi mike
    first of all thank you for the great plugin, i think this is the best contact form plugin ever
    but still i have the same problem as ELsMystERy has 5 months ago
    so have you solved the problem yet?
    otherwise i have to get back using internal wp cron and i hate that

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Fast Secure Contact Form] Session cookie error broke cron jobs in cPanel.’ is closed to new replies.