WordPress.org

Forums

Fast Secure Contact Form
not getting [from-name] to work in subject prefix (15 posts)

  1. dragonsjaw
    Member
    Posted 3 years ago #

    I cannot get the
    [from-name] to work in the email subject prefix.

    http://wordpress.org/extend/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    This is the tag that will work. It has a underscore, not a dash:
    [from_name]

    You can see all the available tags for subject on the form edit page when you click "help" next to the subject setting.

    faq
    http://www.fastsecurecontactform.com/faq

  3. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Oh yeah, be sure to update the plugin also
    3.1.3
    (04 Feb 2012) - Extra field tags can be used in subject setting. For available field tags, click 'help' next to the 'E-mail Subject Prefix:' setting.
    - Fix vCita could not be disabled during invalid email condition.
    - Fix JS on form edit preview page.

  4. dragonsjaw
    Member
    Posted 3 years ago #

    Well that brings up another question..
    will updating the plugin wipe out all the current form settings?

    thanks

  5. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    No it will not, the settings are saved in the WP database.
    You can (and probably should) backup all your forms using the backup tool

    See this help page:
    http://www.fastsecurecontactform.com/backup-restore-forms

    faq
    http://www.fastsecurecontactform.com/faq

  6. dragonsjaw
    Member
    Posted 3 years ago #

    Thanks for your help, I am new to forms, always avoided them.
    I did do a back up this morning when I say the update.

  7. jchechile
    Member
    Posted 3 years ago #

    So I can't for the life of me get this to work..

    here's the subject I'm trying to use:

    Justin Andrew: [form_hours] hours [form_date]

    I have two extra fields and their label is set to "hours" and "date" ...
    the date field is set to type: date and the hours field is just "text"

    But every time I submit the form it just comes back with exactly that in the subject and the script isn't parsing out those form field values.

    Please help?
    I just updated today so I'm using the current version.

  8. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    You have to click 'help' next to the 'E-mail Subject Prefix:' setting to see the available field tags. [form_hours] and [form_date] are probably not the correct tags for extra fields. so lick 'help' next to the 'E-mail Subject Prefix:' setting to see the available field tags and only use the one that are available.

  9. jchechile
    Member
    Posted 3 years ago #

    Thanks for your reply,
    Yeah I saw that advice on here to click on help but what drops down for available tags is this:

    Available field tags:
    [form_label]

    I don't really understand that doesn't seem to be helpful.

  10. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    URL to your form would be needed to help you

  11. jchechile
    Member
    Posted 3 years ago #

  12. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    jchechile, there was a bug I just fixed, it will be fixed in the next version out really soon.

  13. jchechile
    Member
    Posted 3 years ago #

    ah drag. ok, i'll keep an eye out!
    soon you think like days? weeks? (hours? ;])

  14. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Fixed in version 3.1.4

  15. jchechile
    Member
    Posted 3 years ago #

    Brilliant!
    Thank you for being attentive and fixing this so soon! Love the script.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Fast Secure Contact Form
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic