Support » Plugin: Fast Secure Contact Form » [Plugin: Fast Secure Contact Form] Getting a Blank Screen On Settings and Options Pages

  • Ryan

    (@ryangscofieldgmailcom)


    upload and activated with no problems but I get a blank screen on Settings and Options pages. Have you seen this sort of problem before or have any recommendations. Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Check if you have PHP5. Some have reported that their server was PHP4 and it caused this. Upgrade to PHP5. PHP5 is more secure and more reliable. PHP4 is discontinued.

    If that was not it…

    Maybe another plugin is conflicting.
    Look on the Admin – Plugins – menu.
    Temporarily Disable (not uninstall) all your other plugins.
    Does it work now? If yes, Activate the plugins one by one to determine
    which one conflicts. Which plugin was causing it?

    If that was not it..

    I think there is a PHP error on the page. Your server might have PHP error display turned off so it does not show what the error says, that is why the white page.
    Do you have PHP error logs? Look and see what the error says.
    You can also try this temporarily to possibly see the error.

    Edit the wp-config.php file and add this line:
    define(‘WP_DEBUG’, true);

    Be sure to remove it later when done testing as some poorly written
    plugins and themes will display warnings that are not really hard errors just warnings. BTW I program my plugins well enough that there should be no errors or warnings.

    Please report your progress.

    Ryan

    (@ryangscofieldgmailcom)

    Thanks for the quick response. It was the PHP version. I was on 4 and have upgraded to 5 now. No longer have the issue and actually solved a couple of other issues I had been having with updating plugins and wordpress versions.

    Thanks! Great plugin!

    I am on PHP5 and I got the same thing, installed perfectly as usual, went to the settings page and everything is blank.

    Going to re-download then delete the old, upload and and see if that fixes it.

    I’ll report back.

    Thanks.

    Well, it’s still blank on my end. All the previous versions worked great.

    Any other ideas as to why I’m getting a blank screen for the plugins settings page?

    Thanks!

    herbbotany, In this thread I offered 3 things you need to do to diagnose the problem. Did you try all three? What are the results?

    Hi Mike,

    One thing is that before I disabled all the plugins and such, I did go to my page that the contact form is on and it worked. Sent an email perfectly, although on the back end the settings page was still blank.

    I disabled all my plugins, then enabled the contact form, the settings page was back. So then I slowly started to enable all the other plugins (most of which I’ve used previously with your plugin) and the only one that gave me trouble was WP-Ecommerce coming up with a fatal error upon trying to re-enable it. So I’m suspecting that WP-Ecommerce might have been the one that was messing everything up.

    So now I have to reinstall that and see if it was the exact culprit. I’ll get back to you on that if it is.

    Thanks for your support and your plugin! Seems like there is an update to it everyday! :)) I really like it because it’s not bloated and works great and it’s not hard to get up and running like some of the other contact form plugins out there. Ha! Anyhow, thanks again.

    Eric @ Herb Botany

    Hi Mike.

    I’ve got the same problem – blank screen. Interesting is: on my host server show me that is installed PHP5, but on your plugin it show me a warning as I’m using PHP4. Plus, it conflicts with Akismet plugin. How to make them good friends: Akismet and FS Contact Form plugin? 🙂

    I’ve got the last WP3.0.4. Thanks.

    igorsmd, your PHP5 is not initialized.

    When using the Apache web server, typically you can configure it to use PHP5 by doing the following:

    Locate and edit this file, located at the top directory of your WordPress installation: .htaccess

    Add these two lines to the file:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    If that does not help, contact your web host for support.

    Akismet is fully supported, the other problem you have should be fixed, then maybe the Akismet will comply.

    You are genius! It worked!

    There wasn’t any .htaccess file so I created one just with the 2 line you provided. I uploaded it in my top WordPress directory, I reactivate the Akismet and – voala – it’s brilliant! Thanks a lot Mike!!! I can’t believe it yet…… 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Fast Secure Contact Form] Getting a Blank Screen On Settings and Options Pages’ is closed to new replies.