Support » Plugin: Fast Secure Contact Form » [Plugin: Fast Secure Contact Form] Activation generates "unexpected output"

  • Resolved figure8



    Tried FSCF on two different web sites and got messages like this:

    “The plugin generated 229 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.”

    (The other site said 227 characters of unexpected output).

    I disabled all other plugins on the “229” site and tried again; same thing. Before that, I tried using Genesis as the theme and also tried using Twenty Thirteen.

    Anyone else having this problem? Anyone know what’s wrong?

    Thank you in advance.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Did you have 3.xx on previous or was this a new installation?
    Does the plugin still activate and work?
    What version is the plugin you are activating?

    Thanks for replying, Mike.

    1. One site I tested this on was an upgrade from FSCF 3.x. WordPress said “227 characters of unexpected output” for this one. The upgrade was to FSCF 4.0.8, and now has been upgraded to 4.0.9 (which causes the same warning upon activation). FSCF 4.0.9, WP 3.6.1, PHP 5.4, MySQL 5.5.33-31.1.

    2. Another site I tested on (just now) was a brand new WordPress install. This was a clean install — FSCF 3.x was never installed before. This site gives me the “229 characters of unexpected output” message upon activation. This install was FSCF 4.0.9. WP 3.6.1, PHP 5.4, MySQL 5.5.32-cll-lve .

    The plugin activates and sends e-mail from both sites. I’m mostly concerned about security, if something is broken or at least malfunctioning. Do you know what’s going wrong?

    Hi Mike,

    I faced the same issue yesterday on version 4.0.9, and I was on FSF 4.0.6 before to update.
    Then, I deactivate FSF, and reactivate it : same error.
    So I restored FSF version 4.0.6.

    I cannot duplicate this problem. I would need your help to find the cause, then I can fix it.

    How did you install the plugin?
    – Auto install from admin plugins search?
    – FTP upload the files?

    sometimes the files can get corrupted by improper settings in the ftp program. Sometimes characters can get appended to a file when you use the standard FTP transfer. Please transfer using binary mode or just use the WordPress plugin uploader, or install automatically from plugin admin page search and install.

    Can you temporarily insert this code to make it save the error then send it to me?

    If you are receiving plugin or theme activation errors place this snippet of code into plugin.php. It will print out the activation errors to an HTML file to review. You can also alter the script to echo it on screen.

    In the file: wp-admin/includes/plugin.php add to the file at the end (Change the path(wp-content/uploads/2013), this is just an example):

    function save_error(){
    file_put_contents(ABSPATH. 'wp-content/uploads/2013/error_activation.html', ob_get_contents());

    Hello again Mike,

    I have always installed the plugin through the WordPress interface, never FTP.

    I tried adding the bug catching code to the end of plugin.php, but it didn’t output anything. I modified it to “/wp-content/” rather than “wp-content/” and here’s what I got in the html output file:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘FSCF_Util’ does not have a method ‘activate’ in [..]/wp-includes/plugin.php on line 406

    I’m assuming that this doesn’t have much to do with the unexpected output warning though.

    I think that is the error I have to fix, thanks, you can take that test code out now.

    I found the problem and will fix it in the next update. Thanks for helping

    Try version 4.0.10 just released

    Hi Mike,

    Strangely, the update does not happen. During the update process, after 20 seconds, I receive the message that says the download is in progress, but the message appears twice as you can see on this screenshot and nothing happen.
    And I see the “si-contact-form” folder that has not changed on my file server.

    I will try to do a manual update.

    Manual update done. No issue.

    Many thanks Mike

    Updated to 4.0.13 and no unexpected characters generated. Thanks Mike!!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Fast Secure Contact Form] Activation generates "unexpected output"’ is closed to new replies.