Support » Plugin: FAQs Manager » [Plugin: FAQs Manager] Accordeon does not display

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author IndiaNIC

    (@indianic)

    Im sorry - I have seen screenshots before. Could you please specify what you mean? Do you assume Ive made any mistakes in the process or what? Any advice would be appreciated. Thank you in advance.

    Hi, congratulations for your plugin.
    I have the same problem, the accordeon doesn’t work.

    http://adsanjuan.jaimezubiaur.com/index.php/faq/

    Hi – I have spent most of the day trying out different FAQ modules, and this one has the potential to be one of the best. I certainly hope you guys continue updating it.

    I am also having a problem with the accordian, in that it does not show at all. After looking at it for a while – I think it will be OK in its current state for a couple of my sites, so maybe you could consider making “accordian mode” an option?

    There is an error with jquery. The plugin is not getting the code it needs from jquery that runs with wordpress. I added the script for the jquery.min.js that came with the Faqs manager in the plugins folder and the accordion started working.

    I replaced lines 312-314 of inic_faq.php with
    echo "<script type=\"text/javascript\" src=\"{$this->pluginUrl}jquery/jquery.min.js\"></script>\n

    Hope this helps guys!

    brandonmikulka, thanks a lot… unfortunately in my case it didnt work out. But maybe its just because I suck at code editing 🙂 Could you please share your updated inic_faq.php file so we can just overwrite original file?

    Brandonmikulka, thank you very much!
    It works perfectly. I share the file with everyone.

    http://www.jaimezubiaur.com/desarrollo/inic_faq.zip

    No Problem, Thanks JaimeZubiaur for posting the file!

    This is great – thanks very much JaimeZubiaur ; I have multiple FAQ categories displayed on one page – each category under a different heading and with some different introduction text. With this fixed init_faq.php , I get the accordian working for the first instance of the FAQ on the page – but not the others. Any clue as to why this might be ?
    Thanks.

    I am having 3.4.1 version. I tried the file mentioned by JaimeZubiaur. But I still don’t get Accordeon. Any thing else I can check. My Site is http://www.clouni.com/?page_id=41

    You can try this solution for Accordeon problem.
    in iNIC “FAQ’s -> Setting” Under HTML Setting modify the “Custom Js” Script as follows:

    jQuery(document).ready(function() {
        jQuery("#iNICfaqs_questions").accordion({header: ".accordion_header", autoHeight: false,navigation: true,collapsible: true});
      });

    Again this cause by the jQuery conflict.

    I’ve tried the custom JS snippit from @jenagan as well as the updated init_faq.php file from JaimeZubiaur. But some kind of jQuery conflict is causing the top item to display correctly while the others below it do not. See screenshot. If it makes a difference, I’m using Google to host my scripts.

    My FAQ Page

    Screenshot

    Agree with lynx above…

    This only works if you have one FAQ group. I have 4 groups on one page and it doesn’t work for the last three. Please fix! See my website (I’m building it in a temp domain share until it is ready to publish, thats why the URL is weird. NOT a virus)

    See here – http://69.93.203.66/~tempkill/?page_id=842

    Seems like you already read this post.

    http://wordpress.org/support/topic/plugin-faqs-manager-multiple-faqs-in-one-post?replies=1

    I also contacted indianic directly in order to fix this. :>

    Try putting the jQuery script into compatibility mode.

    For me, this fixed the problem:
    in the iNIC FAQ -> Settings, scroll to the bottom to the “Custom JS” field. Change all instances of “$” with “jQuery”.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Plugin: FAQs Manager] Accordeon does not display’ is closed to new replies.