Support » Plugin: FAQ Manager » [Plugin: FAQ Manager] Permalinks for FAQs returning 404 when not in Default Permalinks setting

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Andrew Norcross

    (@norcross)

    while I can’t be certain, make sure you do these things:

    1.) set whatever URL structure you want (don’t leave them blank) in the FAQ Manager settings page

    2.) Save your permalinks after this is done

    3.) delete the ‘FAQ’ page you’ve created. There is most likely a conflict between that and the URL

    Thanks for the quick response. Was hoping deleting the “FAQ” page I created a while back would fix. Unfortunately, it didn’t.

    I tried a couple different URL structures in the FAQ manager settings and that didn’t change anything. I tried to save permalinks after saving the FAQ settings, and that didn’t help. And, as mentioned, I deleted the old “FAQ” pages and repeated the two steps above and am still getting the 404 errors.

    I also just tried the above steps using Twenty Eleven theme and got the same results.

    What do you think?

    Plugin Author Andrew Norcross

    (@norcross)

    Something is interfering with your site URLs. The ‘real’ URL of the one you posted (http://lifeisnoyoke.com/page-with-an-faq-test/) comes up fine. Also, loading the ‘ugly’ URL of the specific FAQ works: http://lifeisnoyoke.com/?question=whats-for-breakfast-this-morning

    if you wanna email me a login, I can take a look. andrew at andrewnorcross.com

    just send you a login. appreciate the help.

    join.me so i can see what you’re doing?

    thanks,

    leonard

    Plugin Author Andrew Norcross

    (@norcross)

    OK. found the culprit. The TDO Tag Fixes plugin was / is causing the problem. I checked the code inside that plugin (which hasn’t been updated since 7/4/2008…over 4 years.) It includes some rewrite rules that are incompatible. Delete that and you’ll be good.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: FAQ Manager] Permalinks for FAQs returning 404 when not in Default Permalinks setting’ is closed to new replies.