FancyBox for WordPress
Fancybox not working on my site (5 posts)

  1. benerrol
    Posted 3 years ago #

    Installed and activated fancybox but no class="fancybox" or rel="fancybox" are added to any of my image links.

    I manually added the class and rel tags on the image on the top left on this page, but still getting nothing.



  2. Have you tried deactivating some plugins. I can see from the source code that you have colorbox, thickbox and fancybox running. There's also a SIFR plugin, 2 contact forms and a couple of different jQueries.

    I'm guessing that there's a conflict somewhere. I would try deactivating the ones you don't need and see if that helps.

  3. benerrol
    Posted 3 years ago #

    Hi Christine, thanks for the reply. I disabled and deleted the plugins you mentioned and still not getting anything. I put up the SIFR plugin back again now since I'm using that.

    It's weird, I did a mock copy of my website on a local setup. Same plugins with the same theme and fancybox seems to work locally but not on my main site. Any other suggestions?

  4. I was playing with the plugin again this morning and noticed that if I insert a gallery, I need to make sure that the radio button "image file" is selected and not page attachement.

    Once image file is selected, then fancybox works, otherwise it doesn't.

    A quick way to check this is in your post, the shortcode should look something like this:

    [gallery link="file"]

  5. benerrol
    Posted 3 years ago #

    Hi Christine..I can't seem to find that 'insert gallery' radio option in the settings. Where can I find it?

    And after that, what if it works but I only wanted to insert one image and not a gallery? How do I go about doing that?

    Thanks, really appreciate the response :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • FancyBox for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic