Support » Plugin: Photo Gallery by 10Web - Mobile-Friendly Image Gallery » Plugin failure to load any images since last update

  • Resolved uofascuba

    (@uofascuba)


    Since the last update to WordPress, our photo gallery plugins stopped loading images. A few days ago, it was just the full lightbox images, but as of today it’s just showing a constant “loading” circle.

    I’ve checked a few other sites that use the plugin from here, and they all seem to work. As for ours, the only time they load images is from the control panel, if I’m doing some tweaking on those galleries.

    Please advise.

    WordPress 5.2.1–en_CA, Photo Gallery 1.5.27

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Yo are NOT alone as we have the same problem and waiting for a proper solution.

    https://www.dropbox.com/s/7cw2vk8tj2nkcpp/Screenshot%202019-06-03%2017.37.13.png?dl=0

    that you don’t need to suggest and the problem is probably related to the one others have here too with uploading as the Gallery simply stops working

    to decrease the images to be uploaded doesn’t bring anything as it was already set to 10 in the last update.

    Do you get the nice browser ICON in a grey screen saying that your domain is not loading – if that is the case then check your HEADERS – you might have mixed headers here defined – SAMEORIGIN and DENY – that can happen when you updated – do a grep check if you have those defined in apache2 config.php security.ini and mods-available headers.load and set both to sameorigin.

    That helped here in some sites to get at least the ADD IMAGES showing again the xframe with the external upload script which is capable to manage all images – uploads etc externally but not from within WP since the last update.

    BUT even that worked no images could be inserted since as the INSERT FROM MEDIA Gallery is still not working. So we still wait for a complete solution too.

    But Your Problem is I guess more related to the fact that you serve the images via HTTP instead of HTTPS which is a MUST in your case – check the console. Install a plugin to get SSL up and running and do a search and replace for all left over http://yourdomain and change them to https://yourdomain

    Mixed Content: The page at ‘https://uofascuba.com/wp/dive-trips/previous-trips/’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘http://main.uofascuba.com/?ga_action=googleanalytics_get_script’. This request has been blocked; the content must be served over HTTPS.

    • This reply was modified 5 months, 1 week ago by  toremo.
    • This reply was modified 5 months, 1 week ago by  toremo.
    Plugin Support kimabaghdasaryan

    (@kimabaghdasaryan)

    Hi,

    Please navigate to photo-gallery/filemanager/view.php file, and search for display function (approximately line 305) and set up limitConcurrentUploads to 1 not 10

    limitConcurrentUploads: 1, // upload step by step

    Please let us know if it helps.

    Thank you!

    Have a nice day!

    shersinghrawat

    (@shersinghrawat)

    I have the same problem since the last update. Till date lightbox not working even after deactivating all other plugins. check the link https://ssssccw.org/gallery/image-gallery/

    uofascuba

    (@uofascuba)

    This problem has NOT been resolved. This thread should not have been marked as such.

    I have changed the plugin view.php file as indicated by @kimabaghdasaryan , but it did not solve the problem.

    I have enabled SSL and, I believe, configured it to serve images by HTTPS. This did not resolve the problem, though I admit I’m not as adept at this as some on this thread.

    (Since I last checked, @toremo has modified their reply a few times and I haven’t had a chance to follow through on the other suggestions. Thank you for being thorough on this!)

    Plugin Support kimabaghdasaryan

    (@kimabaghdasaryan)

    Hi,

    It is highly appreciated if you write the issues in separate forums, so it will not be confusing.

    @shersinghrawat please deactivate your mod cache or autoptimize plugins and check if the issue solves. And also, please check the Developer mode to Yes from Photo Gallery > Options > General. and also set up Lazy Load to No. Please check the screenshot.
    @uofascuba please do the same, please check the Developer mode to Yes from Photo Gallery > Options > General. and also set up Lazy Load to No. Please check the screenshot.

    Thank you!

    Have a nice day!

    Optimizing Matters

    (@optimizingmatters)

    pro-tip; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there are troubleshooting tips and info on how to exclude in the AO FAQ.

    hope this helps debugging,
    frank (ao dev)

    shersinghrawat

    (@shersinghrawat)

    Hi @kimabaghdasaryan

    Photo Gallery Image still not loading in Lightbox even after deleting the auto-optimize plugin, setting Lazy Load to ‘NO’ and Developer mode to ‘Yes’.

    uofascuba

    (@uofascuba)

    @kimabaghdasaryan Disabling Lazy Load and using Developer Mode has solved the problem I came here with. Thank you!

    … but, ironically, now it won’t load in lightbox mode. The gallery preloads just fine, but lightbox just times out.

    Checking the link they provided, it seems to be an identical issue to @shersinghrawat, except we do not use the autooptimize plugin at all. Since they’ve disabled/deleted it, it seems the two of us now have the same problem.

    (It’s not as nice as a new thread, but at least we’re consolidated under one problem now! 🙂 )

    Plugin Support Zhanna Khachatryan

    (@zhannak)

    Hi @uofascuba,

    I have just entered your website, the lightbox is working, can you please recheck? If the issue persists, please make sure to clear your website and browser cache before checking the issue.

    Plugin Support Zhanna Khachatryan

    (@zhannak)

    Dear @shersinghrawat,

    The problem with your gallery is the symbol that you have used in the image description.

    In one of your image descriptions, it is written:

    • Inaugural Session of seven days NSS Camp.

    Please remove the point and space and try to get the same result with HTML li tag.

    Please get back to me with results.

    Hi Zhanna,

    I removed the symbol and space.. but still the lightbox is not working.

    Plugin Support kimabaghdasaryan

    (@kimabaghdasaryan)

    Hi,

    Please download BWGViewGalleryBox.php file from this link and replace it with the current. You can find the file on this path: wp-content/plugins/photo-gallery/frontend/views/BWGViewGalleryBox.php

    Please let us know if you have any questions.

    Thank you!

    Have a nice day!

    @zhannak This is interesting: The lightbox seems to work on the page you linked, but not on any other one, even ones hosting the same gallery, like the site’s home page. That’s what I’d been checking to test if it had been resolved.

    Still, that sounds more like a problem with WordPress specifically than with the plugin, and as long as the page I linked in my topic opener works, I can consider this resolved. Thank you!

    Dear @kimabaghdasaryan

    The file you suggested worked. But there is one problem in the lightbox. In the lightbox window, the current image is displayed with description but when I click on > (next) or <(previous) button, the images are displayed without any description.

    Plugin Support kimabaghdasaryan

    (@kimabaghdasaryan)

    Hi,

    Please try to upload the following file (BWGViewGalleryBox.php) on the same path.

    Thank you!

    Have a nice day!

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.