WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Faceted Search] Search results not coming up correctly

[Plugin: Faceted Search] Search results not coming up correctly

  • Loving40s
    Member

    @loving40s

    I installed Faceted Search a couple weeks ago, tested it out and it worked great. Yesterday I did another test (before going live with my blog), and now the search is not pulling up correct results.

    I’m using the Tag Widget. When I select two tags on the blog to search with, it pulls up only one post when I know that there are 20 posts with these two tags.

    I have deactivated the plugin and then reactivated it, but still not working correctly.

    This is the blog in question: http://www.twific.net

    Any advice?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author AndrewUlrich
    Member

    @andrewulrich

    Hmm, that’s perplexing…

    Those 20 posts each have both tags, right? ‘Cause if they don’t, then it wouldn’t select them. Other than that, I’ve re-checked the code, and can’t find anything wrong at the moment.

    Loving40s
    Member

    @loving40s

    Yes, the 20 posts in question definately have both tags, yet it only pulls up one of them. I tried other searc combinations and am getting a ‘page cannot be found.’

    I have tried deactivating plugin, even deleted it, then reinstalled, but it still doesn’t work right.

    what’s odd is that it did work when I first installed it.

    I have the same problem and as I can remember it worked too when I first installed it.

    Currently I deactivated the plugin but following my details and what I’ve tried so far to make it run:

    WP version: 3.0.1
    MySQL Version: 5.0
    Theme: Twenty Ten 1.2

    deactivated all plugin except FS

    I would really love to get the plugin to work pls!

    Plugin Author AndrewUlrich
    Member

    @andrewulrich

    thanks borisj for confirming this. I’ll work on it some more tonight. In the meantime, I’m uploading a small bugfix that will better handle wpmu sites.

    Plugin Author AndrewUlrich
    Member

    @andrewulrich

    If you could do me a big favor, the following would be helpful for me to debug the issue:
    in faceted-search.php:
    1. uncomment lines 253-256 (take out the //). Don’t uncomment line 257 which has the word “die” in it.
    2. after line 340 (that’s the line that says $query = $query.$queryfrom.$querywhere;), add this line: die(“
    Executed the following query: $query”);
    2. run the search
    3. copy and paste what appears on the screen into an email and send it to me
    4. undo the above changes so your site doesn’t remain broken

    Thkx for your effort, Andrew. Give me ur e-mail address or should I use the contact form on ur HP?

    Regards from rainy Germany
    Boris

    Loving40s
    Member

    @loving40s

    Andrew, do you need the same information from me as well? Still not working properly on my site, and I can’t find any other plugin that will do a tags faceted search.

    Plugin Author AndrewUlrich
    Member

    @andrewulrich

    Borisj,

    Yeah, I think the contact form should work. Thanks a bunch.

    Loving40s

    Yes, if you could as well, it will give me more information to work with.

    Please do it for the searches that don’t work. If you do it for the searches that do work, please label them as so.

    Thanks a bunch!

    Plugin Author AndrewUlrich
    Member

    @andrewulrich

    Ok, I’ve just released version 3.0. It contains an overhaul of the query builders, so let me know if that resolves your problems.

    You can also now choose from inclusive, exclusive, or smart searching. You can find more info about that here.

    Loving40s
    Member

    @loving40s

    Andrew, I’ve tried the newly released version 3.0, and it did not fix the problem.

    Do you still want me to provide you the above information from the faceted search.php? If so, I’ll need a few more instructions as I am not savvy with css.

    I understand instruction #1 and #2, but #3 “run the search”. How do I do that? Will it automatically ‘run the search’ when i enter the code in step 2?

    Thanks!

    Plugin Author AndrewUlrich
    Member

    @andrewulrich

    Due to the changes in the new release, Step 2 has been changed to simply uncommenting line 274 (that is, erase the // from that line). Other than that, it should work the same.

    To ‘run the search’, simply select the appropriate faceted search checkboxes on your front page (or wherever your faceted search widget appears), and click the widget’s search button. Once clicked, it will do a faceted search like usual, but will stop at a certain point and output some information to your screen which I could definitely use.

    One other thing you can modify in the above instructions is change ‘die’ to ‘print’, so your site will still be able to load after you press the search button. In this case, just right click, select ‘view source’, and email the contents of that to me.

    Loving40s
    Member

    @loving40s

    Andrew, I just want to make sure I have all this straight so I don’t jack up my site or something…lol. And also so that you get the information you need.

    in faceted-search.php:

    1. uncomment lines 274 (take out the //).

    2. after line 340 (that’s the line that says $query = $query.$queryfrom.$querywhere;), add this line: print(“
    Executed the following query: $query”);

    3. Go to site and run a faceted search. when results display, right click, select ‘view source’, and email the contents.

    Please confirm the above instructions. Thanks.

    Thanks Andrew for your great engagement. I was off for some days.

    Version 3 seems to work for me. For this I have to mention that I am just about to set up a blog. I have 600+ posts all in one category only and a category structure. To test your plugin I just assigned some of the posts to other categories and did a search. So far, everything is fine except when I do a search with no results. There is only a blank page appearing instead of the search results page “Nothing Found…”. Btw. is there a way (php code) to put the fs widget on a page?

    Anyway, I gonna send you the “results” I get after modifying the plugin as you requested – for V2.3 and V3.0. They might help you to further improve the plugin and to probably fix Loving40s’ issue. Should I also send you the “results” of a “No results” search?.

    Thks! Have a nice Day
    Boris

    Ah, Andrew, I just see that I just can comment on your site but not send you an email. Would you like me to comment the long results… Send me your e-mail address to borisj@web.de

    @loving40s

    When you modify the plugin and do a faceted search there should be a blank page with some characters on it. It could start with:

    POSTED ARRAY: Array
    (
    [visibility] => Array
    (
    [0] => 1
    [10] => 0
    [12] => 0
    [13] => 0
    [14] => 0
    [6] => 0
    [20] => 0
    [7] => 0
    [3] => 0
    [27] => 0
    [4] => 0
    [30] => 0
    [31] => 0
    [35] => 0

    This (long) result you need to copy and send by e-mail.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Faceted Search] Search results not coming up correctly’ is closed to new replies.